[MMS] Not downloading the MMS after the data is turned on

RESOLVED DUPLICATE of bug 878360

Status

Firefox OS
Gaia::SMS
RESOLVED DUPLICATE of bug 878360
5 years ago
5 years ago

People

(Reporter: Anshul, Assigned: ctai)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
STR:
- Turn off the data connection from the settings
- Send an MMS to the device under test
- A message is shown in the messaging app (though no notification in the status bar).
- Turn on the data connection

Expected: Once the data connection is connected, the MMS should be downloaded
Observer: The message is stuck at screen that says "I have sent you a file. It will be available until <date>". Please refer to the attachment.
(Reporter)

Comment 1

5 years ago
Created attachment 755647 [details]
Not able to download MMS after the data connection is available

Updated

5 years ago
blocking-b2g: leo? → leo+

Updated

5 years ago
Assignee: nobody → ctai
Are you use AT&T sim card?
Could you please follow below steps to clarify the problem?
1. Use other smart phone(like Android phone) to send a MMS via this sim card.
=> To clarify the sim card issue,
2. Check the APN settings in FFOS phone(in settings/celluar/messaging)
=> Please double check the id/password/MMSC
3. Receive a MMS on FFOS phone first.
=> This step can clarify some APN settings issue.
4. Send a MMS on FFOS phone.
=> If fail, please send a log with MMS/RIL debug messages.

To enable MMS/RIL debug log, you need to add two lines,
'pref("mms.debugging.enabled", true);'
'pref("ril.debugging.enabled", true);', into /system/b2g/defaults/pref/user.js in device.
Then reboot device or restart b2g service.

detailed step:
adb remount
adb pull /system/b2g/defaults/pref/user.js user.js
[update user.js with adding 'pref("mms.debugging.enabled", true);''pref("ril.debugging.enabled", true);']
adb push user.js /system/b2g/defaults/pref/user.js
adb shell reboot

Please tell me when do you send the MMS. It will help me to find the related logs.
Flags: needinfo?(anshulj)
What is the value in Settings/Cellular & Data/Auto retrieve? "On with roaming", "On without roaming" or "Off" ?

> Created attachment 755647 [details]
> Not able to download MMS after the data connection is available
No need step 4. Send a MMS on FFOS phone.
If step 3 fail, please send a log with MMS/RIL debug messages.
Thanks.

(In reply to Chia-hung Tai [:ctai :ctai_mozilla :cht] from comment #2)
> Are you use AT&T sim card?
> Could you please follow below steps to clarify the problem?
> 1. Use other smart phone(like Android phone) to send a MMS via this sim card.
> => To clarify the sim card issue,
> 2. Check the APN settings in FFOS phone(in settings/celluar/messaging)
> => Please double check the id/password/MMSC
> 3. Receive a MMS on FFOS phone first.
> => This step can clarify some APN settings issue.
> 4. Send a MMS on FFOS phone.
> => If fail, please send a log with MMS/RIL debug messages.
> 
> To enable MMS/RIL debug log, you need to add two lines,
> 'pref("mms.debugging.enabled", true);'
> 'pref("ril.debugging.enabled", true);', into
> /system/b2g/defaults/pref/user.js in device.
> Then reboot device or restart b2g service.
> 
> detailed step:
> adb remount
> adb pull /system/b2g/defaults/pref/user.js user.js
> [update user.js with adding 'pref("mms.debugging.enabled",
> true);''pref("ril.debugging.enabled", true);']
> adb push user.js /system/b2g/defaults/pref/user.js
> adb shell reboot
> 
> Please tell me when do you send the MMS. It will help me to find the related
> logs.
I am wondering this might be the same issue on bug 878360. Still need Anshul provide more information.
Flags: needinfo?(anshulj)
Anshul, could you please attach the log with MMS and RIL if it still happed? 
Please follow below step provide from Paul Yang.

rm user.js 2>/dev/null
adb remount
adb pull /system/b2g/defaults/pref/user.js user.js
sed -i -e '$ a\
pref("ril.debugging.enabled", true);\
pref("mms.debugging.enabled", true);
' user.js
adb push user.js /system/b2g/defaults/pref/user.js
adb shell reboot

## update for replacing user.js script
Flags: needinfo?(anshulj)
(Reporter)

Comment 7

5 years ago
Chia-hung, I see different behavior with the latest gecko and gaia for 1.1 than the one I originally reported. I do see however see three different behaviors though.

STR:
1. Turn off data and reboot the phone
2. Send a MMS to device under test

Observed:

Behavior 1: The MMS is received and the MMS service automatically bring up the MMS APN and downloads the MMS. The MMS in this case is correctly shown.

Behavior 2: The MMS is received but MMS service wasn't able to automatically download the image. As soon as I turned the data on manually the MMS image was downloaded successfully

Behavior 3: I tured off the data again and without rebooting sent another MMS to the device. MMS service showed that the MMS is received but not able to download the image. After turning on the data the image was downloaded but after 10-15 mins (might just be a network issue).

Please find the log attached for behavior 2 and behavior 3.
Flags: needinfo?(anshulj)
(Reporter)

Comment 8

5 years ago
Created attachment 759942 [details]
MMS not downloading automatically if the data is turned off
Anshul, from the log, we can see the mms apn use the same as data connection. Behavior 3 is because of the retry mechanism defined in user story is 4 times( interval 1, 5, 10, and 30 minutes). From my point of view those behaviours are not bugs.

So you need to turn on the data connection first on share apn in current data connection architecture. Please see bug 862764 for more information.

Is that of for you to close this bug if you don't have any question?
Thanks.
Flags: needinfo?(anshulj)
(Reporter)

Comment 10

5 years ago
Chia-hung, could you please also explain the discrepancy between Behavior 1 and Behavior 2?
Flags: needinfo?(anshulj)
Anshul, actually I can't reproduce Behavior 1. My best shot is the timing....Might be the default value of data-enable is on. When booting up, the MMS notification was coming. And we get the value before the value set by Settings AP.
Anshul, I think we can mark this bug as resolved and wontfix, right?
Flags: needinfo?(anshulj)
Anshul, I think your original reported behaviour is the same as bug 878360. I also find a way to reproduce the bug 878360.
See https://bugzilla.mozilla.org/show_bug.cgi?id=878360#c9 for more details.
So I marked this as duplicate 878360.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 878360
Flags: needinfo?(anshulj)
You need to log in before you can comment on or make changes to this bug.