Cannot enter into fullscreen mode after print dialog is opened

VERIFIED FIXED in Firefox 22

Status

()

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: bogdan_maris, Assigned: smaug)

Tracking

({regression})

Trunk
mozilla24
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox22+ verified, firefox23+ verified, firefox24+ verified)

Details

(Whiteboard: [pdfjs-c-ux][pdfjs-f-fixed-upstream]https://github.com/mozilla/pdf.js/pull/3339)

Attachments

(2 attachments)

Reproducible on the latest Beta (BuildID: 20130528181031):
Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20100101 Firefox/22.0
Reproducible on the latest Aurora (BuildID: 20130530004016):
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20130530 Firefox/23.0
Reproducible on the latest Nightly (BuildID: 20130529031131): 
Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20130529 Firefox/24.0

Steps to reproduce:
1. Launch Firefox and load a pdf. 
http://www.cs.princeton.edu/~funk/sig04a.pdf
2. Click on Automatic Zoom dropdown button.
3. Click on Current View button. 
4. Click on Download button and close it.
5. Click on Print button and close it.
6. Click on Switch to presentation mode button.

Expected results:
All buttons work as expected and after trying all the buttons the pdf is usable again.

Actual results:
After clicking Switch to presentation mode, the pdf jumps at the next page.
Same issue appears when using the STR from above and clicking on the displayed page, Automatic Zoom dropdown button (that has changed to Page Fit), Next/Previous Page, Show Thumbnails, Show Document Outline.

Notes:
1. This issue is present on Windows 7 x64 and Mac OS X 10.6.
2. Screencast attached:
http://goo.gl/XQTgJ
3. This issue is a regression

Last good nightly: 2013-03-16
First bad nightly: 2013-03-17

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8f5b1f9f5804&tochange=0b052daa913c
Summary: Pdf remembers next page command on multiple buttons button → Pdf remembers next page command on multiple buttons
Nominating for tracking since this is a regression. Bogdan can you try to narrow the regression window down further by using mozilla-inbound? Seems like the only change in the pushlog is an inbound->central merge containing 171 changes but nothing stands out to me.
On step 6, the browser shall enter into fullscreen mode and clicking shall perform next page operation. So it works as expected on my computer. On your screencast I don't see FF entering presentation/fullscreen mode. How was you able to do that?
Flags: needinfo?(bogdan.maris)
Whiteboard: [pdfjs-c-ux]
(In reply to Yury Delendik (:yury) from comment #2)
> On step 6, the browser shall enter into fullscreen mode and clicking shall
> perform next page operation. So it works as expected on my computer. On your
> screencast I don't see FF entering presentation/fullscreen mode. How was you
> able to do that?

On step 6 it does not enter presentation/fullscreen mode. After following the steps  from comment 0 clicking on presentation/fullscreen mode will not enter fullscreen mode, it will jump to the next page. 

If you have any more questions regarding the issue please let me know.

Just tested on latest nightly on Windows, Linux, Mac again just to confirm that the issue is still there and it is. I will be back with the narrowed regression window.
Flags: needinfo?(bogdan.maris)
Whiteboard: [pdfjs-c-ux] → [pdfjs-c-ux][pdfjs-f-fixed-upstream]https://github.com/mozilla/pdf.js/pull/3339
We'd love to get a fix in for FF22b5 (going to build on Tuesday) since this was fixed upstream.
Alex, not sure we need to uplift it. That's really an edge case and I don't think we have many affected users. The user must set full-screen-api.enabled to 'false' in about:config.
Also, I'm not sure it's a regression either, I cannot replicate it locally on Mac or Windows
Flags: needinfo?
I can reproduce in latest Nightly
http://hg.mozilla.org/mozilla-central/rev/204de5b7e0a6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130606 Firefox/24.0 ID:20130606031128

STR
1. Open http://www.selab.isti.cnr.it/ws-mate/example.pdf
2. Click "Print" button and cancel

3. Attempt to click any pdf.js toolbar button

Actual Results:
If "Print" Button have been clicked once,
"Presentation Mode" Button does not work any more.
Clicking pdf.js toolbar button would go to next page
The next page is displayed when I click any  pdf.js's toolbar button.

Expected results:
Work properly


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/629d94d308dd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130314 Firefox/22.0 ID:20130314214232
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/8c8789fb12a3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130314 Firefox/22.0 ID:20130314222234
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=629d94d308dd&tochange=8c8789fb12a3

Suspected:
3df2b971c106	Bill McCloskey — Bug 671976 - Fix print preview asserts (r=smaug)
Flags: needinfo?
Err: correct str is as follows


STR
1. Open http://www.selab.isti.cnr.it/ws-mate/example.pdf
2. Click "Print" button and cancel
2-1 Click "Presentation Mode" Button

3. Attempt to click any pdf.js toolbar button
Blocks: 671976
Assignee: nobody → bugs
Component: PDF Viewer → Print Preview
Product: Firefox → Core
Summary: Pdf remembers next page command on multiple buttons → Cannot enter into fullscreen mode after print dialog is opened
Duplicate of this bug: 880304
Posted patch patchSplinter Review
Silly me, I should have noticed that Bug 671976 should be done
for pp only. We don't open any magic tab for normal printing.
Attachment #759376 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/ff5a4f1c83c1
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Comment on attachment 759376 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 671976
User impact if declined: see bug summary
Testing completed (on m-c, etc.): land on m-c today
Risk to taking this patch (and alternatives if risky): Should be safe. Just limits the patch for bug 671976 to print preview  
String or IDL/UUID changes made by this patch: NA
Attachment #759376 - Flags: approval-mozilla-beta?
Attachment #759376 - Flags: approval-mozilla-aurora?
Comment on attachment 759376 [details] [diff] [review]
patch

approving small, low risk fix so we don't ship this regression.
Attachment #759376 - Flags: approval-mozilla-beta?
Attachment #759376 - Flags: approval-mozilla-beta+
Attachment #759376 - Flags: approval-mozilla-aurora?
Attachment #759376 - Flags: approval-mozilla-aurora+
Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20100101 Firefox/22.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20100101 Firefox/22.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

Verified as fixed in Firefox 22 beta 5 (buildID: 20130612084701), latest Aurora (buildID: 20130612004016) and latest Nightly (buildID: 20130612031138).
Verified Fixed on FF 23b1:

Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20100101 Firefox/23.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20100101 Firefox/23.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0

Build ID: 20130625125232
I confirm this is fixed on Latest Aurora 24 too:

Build id: 20130711004005
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.