If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Contacts][Dialer] Dialer doesn't show on screen when launching from contacts

VERIFIED FIXED in Firefox 24, Firefox OS v1.1hd

Status

Firefox OS
General
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: askeing, Assigned: Gene Lian (I already quit Mozilla))

Tracking

({regression})

unspecified
1.0.1 IOT3 (3jun)
All
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:tef+, firefox22 wontfix, firefox23 wontfix, firefox24 fixed, b2g18 verified, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 verified, b2g-v1.1hd fixed)

Details

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

4 years ago
Ikura
v1.0.1

## STR:
0. Prepare a contact with phone number in Contacts app.
1. Restart the device.
2. Open Contacts app.
3. Select on contact, open the detail page.
4. Click the phone number field to launch the dialer.
5. After the phone call success, ring off it.
6. Click the phone number field to launch dialer again.

## Expected:
The dialer should be displayed on the screen.

## Actual:
No dialer on the screen.
The phone call run on background, so user can not ring off.
(Reporter)

Updated

4 years ago
blocking-b2g: --- → tef?

Comment 1

4 years ago
It looks like a Gaia bug?

Comment 2

4 years ago
Barker, can Qanalyst take a look at this and try and reproduce on the Inari 1.0.1 latest build?   if it works, then flash the latest Partner build and try again.  Report the results back here.   Thanks

Comment 3

4 years ago
This is a dupe of the dialer issue.
Cellular and Data is not working on leo devices - https://bugzilla.mozilla.org/show_bug.cgi?id=859260

Comment 4

4 years ago
This issue is reproducing on the latest v1.0.1 build as well as the latest partner build. Dialer does not show up on screen when launched the second time. The call still goes through to the other device tho but there is no way to hangup. The only way to end the call is by restarting the device.  

Inari, Build ID: 20130530070213
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/11b55d3ada71
Gaia: ac293ce59acc3bede083fad1b973794fa8bf0253

Inari, Build ID: 20130530053909
Gecko: /rev/
Gaia: 3fe8fac22cf096addb39ba633bd51293be3ebb05

Issue reproduces on v1.1 as well

Unagi, Build ID: 20130529070208
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/6ca32ed2bbc6
Gaia: 8f5ab7bfd4a2921aab4e2de11e0d79a29c1bb062

Comment 5

4 years ago
(In reply to Allen Maxwell from comment #3)
> This is a dupe of the dialer issue.
> Cellular and Data is not working on leo devices -
> https://bugzilla.mozilla.org/show_bug.cgi?id=859260

different device and different builds.  could be gonk related, so lets track them separate for now.

Comment 6

4 years ago
Created attachment 756125 [details]
logcat

Comment 7

4 years ago
Here is a video of the bug: 
http://www.youtube.com/watch?v=uNaPF-U0Nuo&feature=youtu.be
Hi, 

Just for clarification, this has not been reproduced with ikura iot#3 build, w/ commercial RIL. I've tried several times, and not able to reproduce it. 

Buildid: 20130528231041

I think you are testing with a later build, maybe a regression on May 30th build?

Thanks!
David

Comment 9

4 years ago
I was able to reproduce this with the 20130528231041 partner build. Using 4 different SIM cards. 

Inari, Build ID: 20130528231041
Gecko: /rev/
Gaia: 6d1008a5f7b4509dd84eca47d036bc65c462714a
(Reporter)

Comment 10

4 years ago
Ikura
Parter build 20130530
Gaia:     fb8777fc8325a383f20ec88341e72e943d9b4028
Gecko:   
BuildID   20130530054624
Version   18.0

Can reprduce.


BTW, if open Dialer app before launch Contacts app, it works fine.
Ikura 20130530053909 MOVISTAR build(v101)
Unagi 20130530070213 PVT V101 build

I can reproduce it.

I think it might have something wrong in contact app, too.
If I dial the contact in contacts app, hang up it, kill contacts app, and reopen contacts app, the app would be white.
Yeah, I can reproduce it on latest Gecko and Gaia, as for right now.

Comment 13

4 years ago
Is there anyone looking at this bug? Thanks!
Flags: needinfo?
 gtorodelvalle@gmail.com , you should try to tell us more about your build info.
Information like gecko branch, gecko version, gaia branch, gaia version, and device information would help a lot.
(Assignee)

Updated

4 years ago
Flags: needinfo?
(Assignee)

Comment 15

4 years ago
I'll try to look into this from the Gecko side. However, it looks like a Gaia issue to me because it's working well after the Contacts app is killed.

We also need Gaia folks' support at the same time.

Comment 16

4 years ago
Gene is checking gecko part and Tim is checking Gaia part.

Updated

4 years ago
blocking-b2g: tef? → tef+

Comment 17

4 years ago
I can also reproduce this issue with my Ikura.
(Reporter)

Updated

4 years ago
Keywords: regression
Regression window: 5/22-5/23 unagi pvt build
Not gaia issue because all gaia revision during that time works with 5/22 pvt build.
change component to general as it seems like gecko bug
Component: Gaia::Contacts → General
Probably one of

https://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/78664b01f4fc
https://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/1ca54fcf98ea
Component: General → Gaia::Contacts
Component: Gaia::Contacts → General
Seems Gecko, I've tested very old Gaia versions on top of today's Gecko and the failure can be reproduced
(Assignee)

Updated

4 years ago
Assignee: nobody → gene.lian
Dialer app didn't receive system message when it is opened.
If we manually kill dialer app every time when a call end, the problem won't occurs.
:evelyn if that's true the dialer couldn't make two calls as well no?
Alberto is pointing to me to the old bug 818623. It seems a workaround was done in Gaia in that bug but it is not working due to the latest Gecko changes. Gene, can you confirm this just requires a fix in Gecko?
Flags: needinfo?(gene.lian)
(Assignee)

Comment 26

4 years ago
Yes, I'm working on this and will try to fix ASAP.
Flags: needinfo?(gene.lian)
batch update on tef+ milestones. partner to make a final on 6/3 Asia time. TEF+ needs to be resolved by 6/3 to be in the final build. thanks
Target Milestone: --- → 1.0.1 IOT3 (3jun)
(Assignee)

Comment 28

4 years ago
Created attachment 756527 [details] [diff] [review]
Patch
Attachment #756527 - Flags: review?(mounir)
(Assignee)

Updated

4 years ago
Attachment #756527 - Flags: review?(fabrice)
Comment on attachment 756527 [details] [diff] [review]
Patch

Review of attachment 756527 [details] [diff] [review]:
-----------------------------------------------------------------

Fabrice should do the review.
Attachment #756527 - Flags: review?(mounir)
(Assignee)

Comment 30

4 years ago
Created attachment 756548 [details] [diff] [review]
Patch, V2
Attachment #756527 - Attachment is obsolete: true
Attachment #756527 - Flags: review?(fabrice)
Attachment #756548 - Flags: review?(swu)
Attachment #756548 - Flags: review?(mounir)
Attachment #756548 - Flags: review?(fabrice)
(Assignee)

Updated

4 years ago
Attachment #756548 - Flags: review?(mounir)
(Assignee)

Comment 31

4 years ago
Created attachment 756553 [details] [diff] [review]
Patch, V2.1
Attachment #756548 - Attachment is obsolete: true
Attachment #756548 - Flags: review?(swu)
Attachment #756548 - Flags: review?(fabrice)
Attachment #756553 - Flags: review?(swu)
Attachment #756553 - Flags: review?(fabrice)

Comment 32

4 years ago
Comment on attachment 756553 [details] [diff] [review]
Patch, V2.1

Review of attachment 756553 [details] [diff] [review]:
-----------------------------------------------------------------

Per discussion with Gene on the design logic, the code looks good to me.
Attachment #756553 - Flags: review?(swu) → review+
Comment on attachment 756548 [details] [diff] [review]
Patch, V2

Review of attachment 756548 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with nits fixed.

::: dom/messages/SystemMessageInternal.js
@@ +249,5 @@
> +    }
> +    return true;
> +  },
> +
> +  _removeTargetFromListener: function _removeTargetFromListener(aTarget, aManifest, aRemoveListener, aUri) {

nit: is this < 80 characters?

@@ +314,3 @@
>          let targets, index;
>          if (!(targets = this._listeners[msg.manifest])) {
> +          let winCounts = {}; winCounts[uri] = 1;

nit: winCounts[uri] = 1; on its own line, or do:
let winCounts = { uri: 1 };

@@ +319,2 @@
>          } else if ((index = this._findTargetIndex(targets, aMessage.target)) === -1) {
> +          let winCounts = {}; winCounts[uri] = 1;

idem.
Attachment #756548 - Attachment is obsolete: false
(Assignee)

Comment 34

4 years ago
Created attachment 756562 [details] [diff] [review]
Patch, V2.2
Attachment #756548 - Attachment is obsolete: true
Attachment #756553 - Attachment is obsolete: true
Attachment #756553 - Flags: review?(fabrice)
Attachment #756562 - Flags: review+
(Assignee)

Comment 35

4 years ago
https://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/c1cf9c63bc4b
(Assignee)

Comment 36

4 years ago
Birch and inbound are closed now so I cannot land this. Since this is a super urgent issue, land b2g18_v1_0_1 first.
(Assignee)

Comment 37

4 years ago
b2g18: https://hg.mozilla.org/releases/mozilla-b2g18/rev/b8f1af773450

inbound: https://hg.mozilla.org/integration/mozilla-inbound/rev/40a7daac0e2c
Birch is still closed, so land this to inbound.
status-b2g18: --- → fixed
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → fixed
Angela or askeing, please verify this is fixed on next day's 1.0.1 and 1.1 build.  thanks.
Flags: needinfo?(fyen)
Flags: needinfo?(ahubenya)
Keywords: verifyme
https://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/b8f1af773450
status-b2g-v1.1hd: --- → fixed
status-firefox22: --- → wontfix
status-firefox23: --- → wontfix
status-firefox24: --- → fixed
https://hg.mozilla.org/mozilla-central/rev/40a7daac0e2c
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 41

4 years ago
Unagi, 20130531 PVT 1.0.1
  Gaia:     e7114bdf4078274fc127a3b2a58dad91d6884219
  Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/be5c2ee11d02
  BuildID   20130531070208
  Version   18.0
does not contain http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/c1cf9c63bc4b

Unagi, 20130531 PVT v1-train
  Gaia:     e1c59baed29e4665d1da9392f86239272073f07a
  Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/4f318822e72c
  BuildID   20130531070205
  Version   18.0
does not contain https://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/b8f1af773450


Create the local build to verify first, and wait the next PVT build.

Unagi, v1.0.1 local build works fine.
    Gaia mozillaorg/v1.0.1 - f13d8be2ff848bae3d72cd83a69abea5e3572311
    Gecko mozillaorg/v1.0.1 - 3b5f918b2c43ddebc0458457a2f127775b96cead
Verified.
Flags: needinfo?(fyen)
(Assignee)

Updated

4 years ago
Depends on: 878395
(Assignee)

Comment 42

4 years ago
The solution here is still not really complete. Fire a follow-up by Bug 878395.

Fortunately, the current logic is still safe (please see bug 878395, comment #0).
I think it is safe as far as I tested it in Unagi PVT V1Train 20130531230204.
Ikura 20130601 MOVISTAR is good to go.
Set to verified fixed as for now.
Status: RESOLVED → VERIFIED

Updated

4 years ago
Keywords: verifyme
(Assignee)

Comment 45

4 years ago
Just for the records, although this issue is solved and verified, it's safer to include the follow-up patch at bug 878395 no matter for the PTV or vendor's testing build. These two patches should be considered as set.
(Assignee)

Comment 46

4 years ago
s/PTV/PVT/
s/set/a set/

Comment 47

4 years ago
Issue is verified as fixed on the latest v1 and v1.0.1 builds. I was able to make calls with the dealer appearing on screen every single time, by repeating the steps in the video of comment 7.

Unagi, Build ID: 20130603070207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/4785b1353fd7
Gaia: 4de4354e3a99f151a834743c7b03a041ac8db12f

Inari, Build ID: 20130603070208
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/42555e1e72fa
Gaia: fcae23654296c9cc645c2b7e77a2c36bf494803a
status-b2g18: fixed → verified
status-b2g18-v1.0.1: fixed → verified
Flags: needinfo?(ahubenya)
You need to log in before you can comment on or make changes to this bug.