Closed Bug 877700 Opened 7 years ago Closed 7 years ago

Invalid background copy on Git branching site

Categories

(Core :: Graphics: Layers, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla25
Tracking Status
firefox23 --- wontfix
firefox24 + fixed
firefox25 + fixed

People

(Reporter: bas.schouten, Assigned: bas.schouten)

References

()

Details

Attachments

(1 file)

In the demo mentioned below we get a container layer with a visible region larger than its parent. This causes a problem in the D3D10 layer manager where CopySubresourceRegion tries to copy invalid data. This patch fixes that.
Attachment #756013 - Flags: review?(roc)
Blocks: 805406
Given that this blocks one of our long-going top-5 crashers and might fix a substantial portion of that, I'd like to track it somewhere - if only to get things actually moving here.
Oh, and from what I remember, this crash signature also significantly regressed in 25, even though it has been quite high even before.
I believe Joe has landed this patch yesterday.
I tried to, but Inbound was closed. :(
(In reply to Joe Drew (:JOEDREW! \o/) from comment #4)
> I tried to, but Inbound was closed. :(

Ah, yes, same here last 4 times I tried to land it. I'll try again tomorrow.
https://hg.mozilla.org/mozilla-central/rev/de0950887682
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
Is this safe for uplift to older branches as well? 23 is too far gone, but if it helps I'd love to have this for 24.
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #8)
> Is this safe for uplift to older branches as well? 23 is too far gone, but
> if it helps I'd love to have this for 24.

I strongly believe it is, but having it sit on nightly for 1 or 2 days might still be a good idea to make sure I didn't overlook some side-effect.
We could look at an uplift nomination if this is low risk enough, ideally before FF24 gets to Beta.
As Scoobidiver says in bug 805406 that this patch seems to fix 2/3 of the crashes with this PushClipsToDT signature, I think we should try to get this uplifted to 24.
needsinfo on Bas to help with uplift here.
Flags: needinfo?(bas)
If this is making the crash numbers go down -and- it seems stable on nightly so far, we should definitely uplift this!
Flags: needinfo?(bas)
Comment on attachment 756013 [details] [diff] [review]
Bind the source region to the area of the paren layer surface.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Windows Update
User impact if declined: Crashes on websites with certain layer trees
Testing completed (on m-c, etc.): On m-c
Risk to taking this patch (and alternatives if risky): Almost none
String or IDL/UUID changes made by this patch: None
Attachment #756013 - Flags: approval-mozilla-aurora?
Attachment #756013 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Does this need QA? If so, can you please advise on a test?
Flags: needinfo?(bas)
I doubt this is still relevant. Sorry!
Flags: needinfo?(bas)
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.