Proxy: problems w/ "no proxy for"

VERIFIED DUPLICATE of bug 80918

Status

()

Core
Networking
VERIFIED DUPLICATE of bug 80918
17 years ago
17 years ago

People

(Reporter: Denis Vlasenko, Assigned: gordon)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)
BuildID:    2001060703

Cannot load http://172.16.42.71/ (my own machine's addr)
Proxy setup:
HTTP: proxy.tm.odessa.ua:80
No proxy for:
172.16.,127.0.0.1
(or 172.16.*.*,127.0.0.1 - same effect)
Mozilla loads page forever (trying to connect thru proxy?)
172.16.42.71,127.0.0.1 - works fine.
But we have an intranet on 172.16.x.x with multiple Apaches on it.
How I'm supposed to configure that? Have I enter each IP separately?

Reproducible: Always
Steps to Reproduce:
Type http://your.ip.addr.here/<enter> and wait

Comment 1

17 years ago
I had good luck at one point zeroing out the extra bits in the net address. 
vda@port.imtp.ilyichevsk.odessa.ua, can you try "No proxy for 172.16.0.0"?

Comment 2

17 years ago
In fact, this is a duplicate.  Let me know if the .0 trick works, though.

*** This bug has been marked as a duplicate of 80918 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
VERIFIED:
Same problem...
qa to me, clarified summary.
Status: RESOLVED → VERIFIED
Component: Networking: Cache → Networking
QA Contact: tever → benc
Summary: Does not load pages from locally running Apache → Proxy: problems w/ "no proxy for"
(Reporter)

Comment 4

17 years ago
No proxy for: 172.16.0.0,127.0.0.1
does not work for me. http://172.16.42.71/ still goes thru proxy
(in fact, fails to, because 172.16.*.* is behind the firewall)

Comment 5

17 years ago
I don't think any address wildcard formats work currently. Has anyone gotten
this to work?
You need to log in before you can comment on or make changes to this bug.