Switch Reader Mode title to bold for Clear Sans

RESOLVED DUPLICATE of bug 930566

Status

()

RESOLVED DUPLICATE of bug 930566
5 years ago
5 years ago

People

(Reporter: ibarlow, Assigned: marcosadp)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mentor=margaret][lang=css])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Using Clear Sans Light for Reader Mode article titles doesn't look that great. Thankfully bold looks good, so let's change our title styles accordingly.

http://cl.ly/image/0T0m2o003P20

Comment 1

5 years ago
To fix this, it looks like we should play around with the font-weight style here:
http://mxr.mozilla.org/mozilla-central/source/mobile/android/themes/core/aboutReader.css#66
Depends on: 877203
OS: Mac OS X → Android
Hardware: x86 → ARM
Whiteboard: [mentor=margaret][lang=css]
(Assignee)

Comment 2

5 years ago
If this bug only consists of changing .header > h1 font-weight from 300 to bold in the aboutReader.css, I'm done and could submit a patch.
Assignee: nobody → marcosadp
(Assignee)

Comment 3

5 years ago
Created attachment 756597 [details] [diff] [review]
Bug 877783 patch

Changes line 66 of /mobile/android/themes/core/aboutReader.css from font-weight: 300; to font-weight: bold;
Marcos it is helpful to set review flags by going to https://bugzilla.mozilla.org/attachment.cgi?id=756597&action=edit and setting the review drop down to ? and the reviewer field to :Margaret

https://developer.mozilla.org/en-US/docs/Developer_Guide/How_to_Submit_a_Patch#Getting_the_patch_reviewed
(Assignee)

Updated

5 years ago
Attachment #756597 - Flags: review?(margaret.leibovic)
(Assignee)

Comment 5

5 years ago
Done. Thanks for the advice Kevin.

Comment 6

5 years ago
Thanks for the patch, Marcos! I'm going to wait until bug 877203 is fixed before reviewing it, but it looks like it is correct.

Let me know if you need help finding other bugs to work on!
(Assignee)

Comment 7

5 years ago
Thank you Margaret for the help provided thus far. I hope bug 877203 gets fixed soon.

If you know of any other bugs that need some work, please let me know.

Comment 8

5 years ago
Comment on attachment 756597 [details] [diff] [review]
Bug 877783 patch

Marcos, I'm so sorry that bug 877203 has been taking forever to land. I'm clearing review for now, but hopefully we can revisit this whenever bug 877203 is finished.
Attachment #756597 - Flags: review?(margaret.leibovic)

Comment 9

5 years ago
Reminding myself to look into landing this.
Flags: needinfo?(margaret.leibovic)
(Reporter)

Comment 10

5 years ago
Er... Not sure if this landed somewhere else, but our Reader titles are, in fact, already bold :)

Comment 11

5 years ago
Doh, this was fixed by bug 930566. And I was also involved in that bug.

Sorry for the churn, Marcos. Hopefully you still learned something working on this bug. Let us know if you want help finding more bugs to work on!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(margaret.leibovic)
Resolution: --- → DUPLICATE
Duplicate of bug: 930566
(Assignee)

Comment 12

5 years ago
Sure Margaret. Let me know if you need help with some other bugs.

Comment 13

5 years ago
(In reply to Marcos A. Di Pietro from comment #12)
> Sure Margaret. Let me know if you need help with some other bugs.

If you are interested, I just filed bug 999069, which is very similar to this bug. I was going to fix it myself, but I would love help :)

You can also take a look at this site for a big list of other mentor bugs:
http://www.joshmatthews.net/bugsahoy/?mobile=1

Thanks!
You need to log in before you can comment on or make changes to this bug.