Closed Bug 877837 Opened 8 years ago Closed 8 years ago

Add hu and tr to multi-locale APK for Fx23

Categories

(Firefox for Android Graveyard :: General, defect)

22 Branch
ARM
Android
defect
Not set
normal

Tracking

(firefox23+ verified, firefox24+ fixed, relnote-firefox 23+)

RESOLVED FIXED
Firefox 23
Tracking Status
firefox23 + verified
firefox24 + fixed
relnote-firefox --- 23+

People

(Reporter: gueroJeff, Assigned: gueroJeff)

Details

Attachments

(1 file)

Add hu and tr to mobile/android/locales/maemo-locales, then upstream to Aurora and Central.
Beta 3 was just shipped. Can we have some context on these additions?
This was on the roadmap for Fx23 and at risk.  why is this coming in so late?

https://wiki.mozilla.org/Mobile/Roadmap12-13#Firefox_23:_Real_Media_.28Aurora.29
(In reply to Tony Chung [:tchung] from comment #3)
> This was on the roadmap for Fx23 and at risk.  why is this coming in so late?
> 
> https://wiki.mozilla.org/Mobile/Roadmap12-13#Firefox_23:_Real_Media_.
> 28Aurora.29

My apologies, this was a misunderstanding on my part. This is meant for Firefox 23, not Beta. I'll rename the bug.
Summary: Add hu and tr to multi-locale APK for Beta 2 → Add hu and tr to multi-locale APK for Fx23
(In reply to jbeatty from comment #4)
> (In reply to Tony Chung [:tchung] from comment #3)
> > This was on the roadmap for Fx23 and at risk.  why is this coming in so late?
> > 
> > https://wiki.mozilla.org/Mobile/Roadmap12-13#Firefox_23:_Real_Media_.
> > 28Aurora.29
> 
> My apologies, this was a misunderstanding on my part. This is meant for
> Firefox 23, not Beta. I'll rename the bug.

It also doesn't need to be added to Central. Only Aurora.
Assignee: nobody → jbeatty
Comment on attachment 756189 [details] [diff] [review]
Adds hu & tr to mozilla-beta/mobile/android/locales/maemo-locales

Review of attachment 756189 [details] [diff] [review]:
-----------------------------------------------------------------

So, this should be against aurora, not beta. r=me for that.
Attachment #756189 - Flags: review?(l10n) → review+
Comment on attachment 756189 [details] [diff] [review]
Adds hu & tr to mozilla-beta/mobile/android/locales/maemo-locales

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or IDL/UUID changes made by this patch:

Is there anything that can be done to track that this change is uplifted to Beta at the next migration?
Attachment #756189 - Flags: approval-mozilla-aurora?
Attachment #756189 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I put a note in our merge documentation not to revert to beta 22 multilocales (https://wiki.mozilla.org/Release_Management/Merge_Documentation#L10n_data_changes)
(In reply to lsblakk@mozilla.com [:lsblakk] from comment #8)
> I put a note in our merge documentation not to revert to beta 22
> multilocales
> (https://wiki.mozilla.org/Release_Management/
> Merge_Documentation#L10n_data_changes)

Great! Thank you.

I currently don't have commit access, can I ask someone to push this for me please?
Landed as https://hg.mozilla.org/releases/mozilla-aurora/rev/0b4c636386c1.

Marking FIXED, and fixed23, but not fixed24, because that'll only happen once we have done the next migration, and not overwritten the state of aurora with central, but overwritten beta with aurora. I hope that makes sense, aurora stays as it is, plus migrates to beta, central looses and stays on central only.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
OS: Mac OS X → Android
Hardware: x86 → ARM
Flags: in-moztrap?(teodora.vermesan)
Test Cases added in moztrap:
Hungarian: https://moztrap.mozilla.org/manage/case/8443/
Turkish: https://moztrap.mozilla.org/manage/case/8444
Flags: in-moztrap?(teodora.vermesan) → in-moztrap+
relnote-firefox: --- → ?
Target Milestone: --- → Firefox 23
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.