If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[mach] intermittant hang flushing build output log

RESOLVED WORKSFORME

Status

()

Core
mach
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: rillian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Twice today, building today's m-c I've had mach hang with the following backtrace. Ctrl-C recovers, and re-running succeeds. Fedora 18 x86_64, python 2.7.3.

 3:28.19   adding: install.rdf (deflated 51%)
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/threading.py", line 551, in __bootstrap_inner
    self.run()
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/home/giles/mozilla/firefox/testing/mozbase/mozprocess/mozprocess/processhandler.py", line 698, in _processOutput
    self.processOutputLine(line.rstrip())
  File "/home/giles/mozilla/firefox/testing/mozbase/mozprocess/mozprocess/processhandler.py", line 663, in processOutputLine
    handler(line)
  File "/home/giles/mozilla/firefox/python/mach/mach/mixin/process.py", line 86, in handleLine
    line_handler(line)
  File "/home/giles/mozilla/firefox/python/mozbuild/mozbuild/mach_commands.py", line 244, in on_line
    self.log(logging.INFO, 'build_output', {'line': line}, '{line}')
  File "/home/giles/mozilla/firefox/python/mach/mach/mixin/logging.py", line 54, in log
    extra={'action': action, 'params': params})
  File "/usr/lib64/python2.7/logging/__init__.py", line 1203, in log
    self._log(level, msg, args, **kwargs)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1258, in _log
    self.handle(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1268, in handle
    self.callHandlers(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1308, in callHandlers
    hdlr.handle(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 748, in handle
    self.emit(record)
  File "/home/giles/mozilla/firefox/python/mozbuild/mozbuild/mach_commands.py", line 76, in emit
    self.footer.draw()
  File "/home/giles/mozilla/firefox/python/mozbuild/mozbuild/mach_commands.py", line 185, in draw
    self._fh.flush()
IOError: [Errno 5] Input/output error

Comment 1

4 years ago
This is very interesting! You can disable the footer by exporting MACH_NO_TERMINAL_FOOTER to your environment.

Is there anything special about your environment? Uncommon terminal application? Running through screen or tmux, etc?
Flags: needinfo?(giles)
(Reporter)

Comment 2

4 years ago
No, bash running in gnome-terminal with no intermediates.

Of course, it hasn't happened since I filed the bug...

Do you want me to try to reproduce with the mach from that day?
Flags: needinfo?(giles)

Comment 3

4 years ago
It's possible this was fixed in another bug. I'm still making my way through 1000+ build config bug updates during the 2 weeks I was out...

Perhaps you should mark WORKSFORME and reopen if it occurs again?
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.