Closed Bug 878019 Opened 8 years ago Closed 8 years ago

IonMonkey: Arm regression on raytrace due to disabled LICM

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla24

People

(Reporter: h4writer, Assigned: h4writer)

References

Details

Attachments

(1 file)

Bug 865406 decreased our performance on raytrace on ARM with 42%. This is because we are disabling LICM on :709 in ARM, but not in the normal execution. Investigating now why we are disabling it (i.e. why we bailed more than 10 times in that script)
Blocks: 865406
So we were constantly invalidating, since even after LICM is disabled we are bailing in that script. As consequence after every 10th bail we invalidated again. This patch should give most of our performance back.

I will still look into the fact why we are bailing, since we don't bail on x86. And I thought there was no differences between ARM and x86 in reasons to bail...
Assignee: general → hv1989
Attachment #756497 - Flags: review?(jdemooij)
Comment on attachment 756497 [details] [diff] [review]
Disable invalidating when LICM is already disabled

Review of attachment 756497 [details] [diff] [review]:
-----------------------------------------------------------------

Good catch.
Attachment #756497 - Flags: review?(jdemooij) → review+
awfy reports:
ARMv7: raytrace: 84.1%
FFOS: ss-cordic: 59.5%
https://hg.mozilla.org/mozilla-central/rev/c906ade40ac9
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
You need to log in before you can comment on or make changes to this bug.