Move handle generation to after PSM setup

RESOLVED FIXED in mozilla24

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: abr, Assigned: abr)

Tracking

unspecified
mozilla24
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRTC][blocking-webrtc-][qa-])

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Bug 874306 caused a regression on B2G since PSM isn't started when
PeerConnectionImpl is initialized.
(Assignee)

Comment 1

6 years ago
Created attachment 756588 [details] [diff] [review]
Move handle generation to after PSM setup

Move handle generation (and its associated calles to PK11_GenerateRandom)
after PSM is set up.
(Assignee)

Updated

6 years ago
Attachment #756588 - Flags: review?(rjesup)
Whiteboard: [WebRTC][blocking-webrtc-]
Attachment #756588 - Flags: review?(rjesup) → review+
https://hg.mozilla.org/mozilla-central/rev/ac483563ea14
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Whiteboard: [WebRTC][blocking-webrtc-] → [WebRTC][blocking-webrtc-][qa-]
You need to log in before you can comment on or make changes to this bug.