Closed Bug 878108 Opened 6 years ago Closed 6 years ago

Support hardware decoding on gonk-JB

Categories

(Core :: Audio/Video, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 871364

People

(Reporter: mwu, Assigned: ikumar)

References

Details

No description provided.
blocking-b2g: --- → koi?
To take this one first.
Current status is that gecko can be built successfully with MOZ_OMX_DEOCDING enabled but temporarily disabling the video decoding path.
Assignee: nobody → mchen
After listing all of OMX components, there is no hw decoding component for audio (ex: mp3). So I can't test audio hw decoding. But sw OMX decoding works already.

Move to enable video SW/HW decoding now.
Marco: I was able to compile with MOZ_OMX_DECODING with parts of the camera patch (bug 871364) from Michael. Mostly the GonkNativeWindow stuff. I did run into the GraphicBuffer declaration mismatch which I have temporarily commented out.
Its not working yet. Debugging through it.
(In reply to Inder from comment #3)
Hi Inder,

Thanks for your information.
If I got any progress, I will update it too.
Marco, are you actively working on this bug?  If so we have a duplication of effort.
Hi Michael,

I am starting to work a few days ago because I didn't get information of your team will contribute to this one. If you already work on it then you are welcome to take it. Because I try to study graphic part and work on it in the same time.
I don't really care who works on it TBH, just that we don't duplicate the effort :)

But since Inder has OMX video history and is making progress, lets let him take this bug for now.
Assignee: mchen → ikumar
(In reply to Michael Vines [:m1] [:evilmachines] from comment #7)
> I don't really care who works on it TBH, just that we don't duplicate the
> effort :)
> 
> But since Inder has OMX video history and is making progress, lets let him
> take this bug for now.

No problem. It is welcome to contribute anything by anyone.
Hw decoding could be enabled by attachment 774281 [details] [diff] [review] in Bug 871364.
Sotaro: do you want to just call this bug a duplicate of bug 871364? It seems you are working on both the issues.
I want to set as dup of bug 871364. And change the bug 871364 as bug of GonkNativeWindow.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 871364
blocking-b2g: koi? → 1.3?
blocking-b2g: 1.3? → ---
You need to log in before you can comment on or make changes to this bug.