If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Use volatile page support for holding in-memory caches

RESOLVED DUPLICATE of bug 748598

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 748598
4 years ago
4 years ago

People

(Reporter: mwu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
See https://lwn.net/Articles/548111/ about adding support for volatile page ranges.

We can tell the kernel about pages that can be dropped when low memory watermarks are hit and put various caches in there like image caches so the kernel can automatically determine when to drop caches.
Note these volatile ranges are not even landed in mainline yet.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 748598

Comment 2

4 years ago
fyi, john is adding this specifically with our android linker in mind :)
You need to log in before you can comment on or make changes to this bug.