[SMS] Select all button not working exactly in the following scenarios

VERIFIED FIXED in 1.1 QE2 (6jun)

Status

Firefox OS
Gaia::SMS
P1
blocker
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Leo, Assigned: steveck)

Tracking

unspecified
1.1 QE2 (6jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
1. Title: Select all button not working exactly in different scenarios
2. Precondition: SMS app should be working
3. Tester's Action: (1) Open SMS -> On thread_list -> Go to Edit mode -> click on select all button -> Receive new sms from the number which is not existing in  the list -> The "Select all" button is not enabled.
(2) Open SMS -> On thread_list -> Go to Edit mode -> Delete the existing thread -> Agian go to Edit screen - > click on select all button -> The "Select all" button is not disabled even when all the messages are selected after delete operation.
(3) Open SMS -> open any thread -> Go to Edit mode -> click on select all button -> Receive new SMS from the current thread number -> The "Select all" button in Edit message screen is not enabled when new SMS is received.
4. Detailed Symptom (ENG.) :The "select all" button working different in different scenarios
5. Expected: The "select all" button should work properly in all the scenarios.
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia Master/v1-train: Reproduced on v1-train/master
8. Gaia Revision:  86fc1cf08c50090a46fc56c5ffa0e7c07cfb1386
9. Personal email id: sasikala.paruchuri8@gmail.com
(Reporter)

Comment 1

5 years ago
Created attachment 756967 [details]
Screenshot attached for First Scenario
(Reporter)

Comment 2

5 years ago
Created attachment 756968 [details]
Screenshot attached for Second Scenario
(Reporter)

Comment 3

5 years ago
Created attachment 756969 [details]
Screenshot attached for Third Scenario
(Reporter)

Updated

5 years ago
Severity: minor → blocker
blocking-b2g: --- → leo+
Priority: -- → P1
Target Milestone: --- → 1.1 QE2 (6jun)
(Assignee)

Comment 4

5 years ago
(In reply to Leo from comment #0)

> (2) Open SMS -> On thread_list -> Go to Edit mode -> Delete the existing
> thread -> Agian go to Edit screen - > click on select all button -> The
> "Select all" button is not disabled even when all the messages are selected
> after delete operation.

I could not reproduce this scenario. Could you please add more description about the step?

Hi Paul, could you please help verify this issue? Thanks.
Keywords: qawanted
(Reporter)

Comment 5

5 years ago
I am testing this scenario again in v1-train.
I will update to you with more description once done
(Reporter)

Comment 6

5 years ago
(In reply to Steve Chung from comment #4)
> (In reply to Leo from comment #0)
> 
> > (2) Open SMS -> On thread_list -> Go to Edit mode -> Delete the existing
> > thread -> Agian go to Edit screen - > click on select all button -> The
> > "Select all" button is not disabled even when all the messages are selected
> > after delete operation.
> 
> I could not reproduce this scenario. Could you please add more description
> about the step?
> 
> Hi Paul, could you please help verify this issue? Thanks.
Description for case (2)
Steps to reproduce:
1.Open SMS application.
2.Delete one of the existing thread from the thread_list.
3.Click on Edit -> Select all. The "Select all" button is not disabled even when all the messages are selected.
Here we should call 'checkInputs' method of ThreadUI & ThreadUIList... I think it should work. Tomorrow I will try this solution if nobody takes this bug before.
(Assignee)

Updated

5 years ago
Assignee: nobody → schung

Comment 8

5 years ago
Unable to repro on
Leo Build ID: 20130603070207
Kernel Date: Apr 25
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/4785b1353fd7
Gaia: 4de4354e3a99f151a834743c7b03a041ac8db12f

'Select All' button is disabled once it has already been selected.  The "select all" button working different in the different scenarios listed above
Keywords: qawanted
(Assignee)

Comment 9

5 years ago
Created attachment 757993 [details]
Patch for fixing select all buttonstatus.

Hi Borja, I sent a patch for fixing the select all button in thread list view, and I think it already works correctly in thread view. So I could not reproduce the (3) scenario. Could you please take some time to verify that? Thanks.
Attachment #757993 - Flags: review?(fbsc)
Steve, I will test the third scenario asap. I've added a small comment in the PR, it's a suggestion. Wdyt?
(Reporter)

Comment 11

5 years ago
@Borja Salguero,
The third scenario works fine as the dependency patch with Bug 874155 is already fixed.
(Assignee)

Comment 12

5 years ago
Hi Borja,
Seems third scenario works fine in the current build. I also left some comment based on your suggestion.
Comment on attachment 757993 [details]
Patch for fixing select all buttonstatus.

Working as expected. Please fix the small issue in the linting and we are ready to merge. Thanks!
Attachment #757993 - Flags: review?(fbsc) → review+
(Assignee)

Comment 14

5 years ago
Landed in master : d82aa503f0476d2e28fb7d1515e4132161ee93ef
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-b2g18: --- → affected
Resolution: --- → FIXED
Uplifted d82aa503f0476d2e28fb7d1515e4132161ee93ef to:
v1-train: cb827db80093d8d217bbff3f7099546731c18dce
status-b2g18: affected → fixed

Comment 16

5 years ago
Verified fixed on:
Device: Leo phone 
Build Identifier: 20130611074722
Update channel: leo/1.1.0/nightly
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8d0562d20324
Gaia: 8c64e19b82d4e0490a7780232d3d6bd07d0ba9ec1370937291
Git commit info: 2013-06-11 07:54:51 
OS version: 1.1.0.0-prerelease

and

Device: Unagi phone 
Build Identifier: 20130611074722
Update channel: unagi/1.1.0/beta
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8d0562d20324
Gaia: 8c64e19b82d4e0490a7780232d3d6bd07d0ba9ec1370937291
Git commit info: 2013-06-11 07:54:51 
OS version: 1.1.0.0-prerelease

Prerequisites:
3 phones with SIM Cards and SMS package enabled are needed. On the first 2 phones, store the number of the other phone under the name of a contact. For example,
John Doe 26853793 on phone #1 when the number of phone #2 is 26853793. 
Jane Doe 53934783 on phone #2 when the number of phone #1 is 53934783.
Send messages back and forth between the 2 contacts using the phones.

Scenario #1
Steps to Reproduce:
1. On the B2G phone home screen, tap on the messages icon to launch the messaging (SMS) app.
2. On the Messages screen, tap on the contact name.
3. On the Contact screen, tap on the Edit icon in the top right hand corner.
4. On the Edit Messages screen, tap on the Select all button. Verify that all messages are selected.
5. Using the 3rd phone, send a message to this phone.

Expected Result:
The "Select all" button is disabled. There is a notification about a new incoming message in the Notification Center.

Actual Result:
Matches the expected result.
********

Scenario #2
Steps to Reproduce:
1. On the B2G phone home screen, tap on the messages icon to launch the messaging (SMS) app.
2. On the Messages screen, tap on the contact name.
3. On the Contact screen, tap on the Edit icon in the top right hand corner.
4. On the Edit Messages screen, tap on the check box next to any one single message. Tap on the Delete button. Verify that the selected message has been deleted.
5. On the Contact screen, tap on the Edit icon in the top right hand corner.
6. On the Edit Messages screen, tap on the Select all button. Verify that all messages are selected.

Expected Result:
The "Select all" button is disabled. 

Actual Result:
Matches the expected result.
********

Scenario #3
Steps to Reproduce:
1. On the B2G phone home screen, tap on the messages icon to launch the messaging (SMS) app.
2. On the Messages screen, tap on the contact name.
3. On the Contact screen, tap on the Edit icon in the top right hand corner.
4. On the Edit Messages screen, tap on the Select all button. Verify that all messages are selected.
5. Using the same phone from which these messages have been received, send another message to this phone.

Expected Result:
The "Select all" button is enabled. The new incoming message is displayed on the Edit Messages screen and is not selected.

Actual Result:
Matches the expected result.
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified
You need to log in before you can comment on or make changes to this bug.