Closed Bug 878491 Opened 7 years ago Closed 7 years ago

About:home is cut off beneath title bar after OOM kill on non-about:home page

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 24
Tracking Status
firefox23 + verified
firefox24 + verified

People

(Reporter: bnicholson, Assigned: bnicholson)

References

Details

(Whiteboard: [testday-20130726])

Attachments

(1 file)

I'm still seeing bug 869411 in the latest Nightly.

STR:
1) Open Fennec and see about:home
2) Go to google.com
3) Minimize Fennec and cause it to be killed in the background (i.e., open several other apps or use oom-fennec)
4) Reopen Fennec
5) Click back to go to about:home

After doing this, the top of about:home is cut off.
Bug 869411 did fix the case where the activity is destroyed/recreated while about:home is showing, but I must have forgotten to test the case where about:home isn't visible (as in the STR above). When we leave about:home, we fully remove (not just detach) the fragment, so it is no longer managed by the FragmentManager and its state isn't saved.
Saves the about:home padding state in BrowserApp instead of the AboutHome fragment since the fragment won't save state after being removed. We'll have to end up doing this anyway with our new about:home changes since HomePager isn't a fragment.
Attachment #757056 - Flags: review?(lucasr.at.mozilla)
Summary: About:home is (still) cut off beneath title bar → About:home is cut off beneath title bar after OOM kill on non-about:home page
Attachment #757056 - Flags: review?(lucasr.at.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/b14bfecb7c34
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
I can verify this is fixed in a Galaxy S2 phone with Android 4.0.3 and the latest Firefox Beta.
Whiteboard: [testday-20130726]
I am unable to reproduce the issue on Firefox Mobile 23 RC and Aurora 24.0a1 2013-07-31 on the Samsung Galaxy R (Android 2.3.4)
You need to log in before you can comment on or make changes to this bug.