Provide API to access OS desktop file search

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: brettz9, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803




Expected results:

The only basic category of functionality of the desktop I can think of which does not appear exposed to the powerful XPCOM platform as an interface would be desktop file search. Would it be very difficult to implement this?
(Reporter)

Updated

5 years ago
Severity: normal → enhancement

Comment 1

5 years ago
Why would we make this part of the platform instead of letting you implement it yourself?
Flags: needinfo?(brettz9)
(Reporter)

Comment 2

5 years ago
Hi,

If you mean why don't I contribute the code, I am currently only familiar with JavaScript.

If you mean to ask what the advantage would be to bundling it with Firefox, I would like to see the functionality available to extensions in any standard Firefox installation, and I think it is a strong enough feature that others ought to as well.
Flags: needinfo?(brettz9)

Comment 3

5 years ago
I don't think that's a sufficient reason. You should be able to implement this yourself using JS-ctypes, and we don't want to add extensive functionality to the core platform that isn't actually part of the product.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

5 years ago
What is "part of the product"? Firefox allows access to the file system... Why stop there? You can't say it's because it's limited to web features because it's not. It's just one feature. I may look into JS-ctypes, but I really hope you may reconsider this. This is the only functionality I see remaining that limits JS developers from letting users live in the browser (e.g., as part of a desktop file browser extension).

Comment 5

5 years ago
"Part of the product" means "the features we need to implement Firefox". Currently we need file access to do that, but not desktop search. Adding feature code which will not be part of the product incurs significant costs, including the risk that it will break and nobody will know because few of our nightly/aurora/beta testers will be exercizing it.
(Reporter)

Comment 6

5 years ago
Ok, then, I would like to reorient this bug a little to ask you to consider the benefit of adding the feature AS part of the product. For example, just as Firefox can browse the desktop in a minimal way, I would envision the possibility for a query option to simply list all files matching a given search term. This might fit in nicely with the view shown when browsing local files (a simple textbox to allow search results to open in a new tab would work from my point of view).

Might not be "Boot to Gecko", but it at least would provides the same nicely feature-complete environment. Then you'd provide a useful feature to users who utilize the desktop browser and possibly give ideas to core developers or extenders for making it better.
You need to log in before you can comment on or make changes to this bug.