Closed Bug 878705 Opened 7 years ago Closed 7 years ago

Clicking near scrollbar thumb scrolls down a page

Categories

(Core :: Widget: Cocoa, defect)

x86_64
macOS
defect
Not set
minor

Tracking

()

VERIFIED FIXED
mozilla24
Tracking Status
firefox21 --- unaffected
firefox22 --- unaffected
firefox23 + verified
firefox24 --- verified
firefox-esr17 --- unaffected

People

(Reporter: jruderman, Assigned: mstange)

References

Details

(Keywords: regression, Whiteboard: [lion-scrollbars+])

Attachments

(2 files, 2 obsolete files)

1. Load a page that scrolls
     (e.g. https://www.squarefree.com/)
2. Scroll to make the scrollbar appear.
     (e.g. using two fingers on the trackpad)
3. Click 1 pixel or 2 pixels to the LEFT of the scrollbar thumb.

Result: Firefox scrolls down a page, as if I had clicked BELOW the thumb.
Attached patch patch (obsolete) — Splinter Review
The left border of the scrollbar isn't covered by the scrollbar thumb, so clicks to it don't end up in nsSliderFrame::StartDrag, but in nsSliderFrame::HandlePress (normal case) or in the scroll-to-click branch of nsSliderFrame::HandleEvent (scroll-to-click case).
This patch makes us ignore clicks next to the thumb.
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Attachment #757399 - Flags: review?(roc)
Attached patch patch (obsolete) — Splinter Review
Attachment #757399 - Attachment is obsolete: true
Attachment #757399 - Flags: review?(roc)
Attachment #757455 - Flags: review?(roc)
Markus, is this ready to be pushed? If so, I can land it if you like.
Unfortunately not yet. Tryserver found a bug in the patch, there's one condition that I missed in the refactoring.
Attached patch patchSplinter Review
The previous patch didn't make sure that clicking with the wrong mouse button causes no scrolling. It only checked it for the scroll-to-click case.
Attachment #757455 - Attachment is obsolete: true
Attachment #760775 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/1ac9367a6c23
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Markus, would you have a problem with uplifting this to Aurora? If not, could you request approval for aurora? Thanks!
comment #9
Flags: needinfo?(mstange)
Comment on attachment 760775 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 636564
User impact if declined: unintended scrolling when clicking in the wrong place
Testing completed (on m-c, etc.): 5 days on mozilla-central
Risk to taking this patch (and alternatives if risky): low risk
String or IDL/UUID changes made by this patch: none
Attachment #760775 - Flags: approval-mozilla-aurora?
Flags: needinfo?(mstange)
Attachment #760775 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:23.0) Gecko/20100101 Firefox/23.0

Verified as fixed on Firefox 23 beta 9 (buildID: 20130725195523) and latest Nightly (buildID: 20130725171558).
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:26.0) Gecko/20100101 Firefox/26.0

Verified as fixed on Firefox 24 beta 2 (buildID: 20130812173056) and latest Nightly (buildID: 20130813030205).
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.