Closed Bug 878762 Opened 8 years ago Closed 8 years ago

(Australis) API add/move/remove should also work when in customization mode

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 876926

People

(Reporter: Gijs, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:M8])

When writing tests for bug 878452, I noticed that the removeWidgetFromArea code breaks some things when using it while the user is in customization mode. AFAICT it leaves the wrapper empty (and doesn't remove the wrapper). It may also not add a wrapper when adding the item to the palette (but I haven't checked this).

Because we expose these APIs, they should probably be footgun-proof for add-on authors in case they try to use it while the user is in customization mode.
Whiteboard: [Australis:M?] → [Australis:M8]
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 876926
You need to log in before you can comment on or make changes to this bug.