Closed Bug 879145 Opened 7 years ago Closed 2 years ago

[Keyboard][User Story] User dictionary in word-suggestion

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(feature-b2g:3.0?, tracking-b2g:+)

RESOLVED WONTFIX
feature-b2g 3.0?
tracking-b2g +

People

(Reporter: sync-1, Assigned: mnjul)

References

Details

(Keywords: feature, foxfood, Whiteboard: [priority])

User Story

As a user, I want the option to add my own words into the dictionary so that they appear in the word prediction fields when typing.
AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.121
 Firefox os  v1.0.1
 Mozilla build ID:20130527070203
 
 DEFECT DESCRIPTION: It is not possible to add new words on SMS dictionary.
 
  EXPECTED BEHAVIOUR: Device must allow to introduce new words on dictionary.
 
  REPRODUCING PROCEDURES:
 1.- Go to Settings/Keyboard/Word suggestion (select ON)
 2.- Then go to SMS/write new SMS...you will see device shows "word suggestions" try to add a new word on SMS dictionary, you will noticed it is not possible to add new words.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT: Wrong interface.
 
  REPRODUCING RATE: 100%
 
  For FT PR, Please list reference mobile's behavior:
blocking-b2g: --- → tef?
Component: Gaia → Gaia::SMS
triage with tef: this is feature request. koi? for future consideration
blocking-b2g: tef? → koi?
Component: Gaia::SMS → Gaia::Keyboard
Not taking features for v1.2.
blocking-b2g: koi? → 1.3?
Add to backlog.
Blocks: 908549
blocking-b2g: 1.3? → -
Summary: [Buri][IOT][SMS] it is not possible to add new words on SMS dictionary → [Buri][IOT] Support user dictionary in word suggestion and auto-correct.
blocking-b2g: - → backlog
Whiteboard: [priority]
Flags: needinfo?(bhuang)
in the priority list, we'll tackle it after the current keyboard refresh.
Flags: needinfo?(bhuang)
feature-b2g: --- → 2.2?
Let's use this as the feature bug?
Flags: needinfo?(bhuang)
User Story: (updated)
Flags: needinfo?(bhuang)
Summary: [Buri][IOT] Support user dictionary in word suggestion and auto-correct. → [Keyboard][User Story] User dictionary in word-suggestion
See bug 983043 for UX spec update.
Hi John, please put those underlying work to this bug, thanks
Assignee: nobody → jlu
feature-b2g: 2.2? → 2.2+
Depends on: 1098124
Depends on: 1102831
Depends on: 1102834
Depends on: 1102835
QA Whiteboard: [COM=Gaia::Keyboard]
Side note: Just inquired the case-sensitivity for user dictionary words of Omega and he says the words should be case-sensitive.
Hi Omega,

What should I do when the user is trying to add an existent word to the dictionary? Thanks.
Flags: needinfo?(ofeng)
When adding an existent word and back to the word list, keep only one instance of that word in the list.
Flags: needinfo?(ofeng)
Mass-unassign feature-b2g: 2.2+ to re-scope 2.2 features.
feature-b2g: 2.2+ → ---
tracking-b2g: --- → +
Hi Omega,

We're checking if "one-character" and/or "two-character" words are allowed (i.e if minimal word length should be 3, or something else).

If so, we probably need to show a message of such limitation when needed. Please advise (& update spec if needed). Thanks!
Flags: needinfo?(ofeng)
I think the minimal word length is 1. Is that possible?
Flags: needinfo?(ofeng) → needinfo?(jlu)
Yes that's possible (i.e. we disallow empty string only). Thanks!
Flags: needinfo?(jlu)
Duplicate of this bug: 1116095
feature-b2g: --- → 3.0?
Marking 2.2 features for 3.0 considerations.
Depends on: 1129844
Depends on: 1130312
Depends on: 1130317
See Also: → 1138782
Depends on: 1139766
blocking-b2g: backlog → ---
FYI: Benchmarks on user dictionary settings UI and predictions performance (latency), in relation to the size of user dictionary (i.e. number of words) are available at bug 1102835 comment 16.
I'm happy to announce that the major engineering bugs have been finished and the first version of the feature is now done and accessible in Settings -> Keyboards -> Built-in Keyboards. Comments and suggestions are as always very much welcome and appreciated.

The enabledness of this feature is currently controlled by |GAIA_KEYBOARD_ENABLE_USER_DICT| build flag, which currently defaults to 1 ("enabled") in Gaia Makefile.
Also, a patch to remove the build flag and formally/completely integrate the feature is at the tip of https://github.com/mnjul/gaia/commits/bug_1102835_formal_enable .
Awesome work guys, thank you! This was the last really needed feature for me in FFOS.
(In reply to John Lu [:mnjul][Please NI or I'll miss] from comment #19)
> I'm happy to announce that the major engineering bugs have been finished and
> the first version of the feature is now done and accessible in Settings ->
> Keyboards -> Built-in Keyboards. Comments and suggestions are as always very
> much welcome and appreciated.


Hi Jon - I did have a bit of feedback on this feature - It does not seem to handle 2-part words well if they include a space. For example: If I add 'zug zug' to my dictionary, and then launch sms and begin typing, after I type the first 'zug' and hit space it corrects it to 'zig'. 
If the feature is not meant to handle words with spaces in them - it might be a good idea to either disable the space-bar input for the add word screen or provide a warning that it might not work for words containing spaces.
I realize I'm probably mis-using the feature here but I imagine some users might expect it to accommodate phrases as well and might interpret it as not-working-correctly.

On the positive side, it handles odd punctuations very well, for example: Ya'll or Dab-oo were recognized without a hitch. 

You also mentioned this is the first version of the feature so something that might be added to the drawing board for a later version (if it isn't already there) is the ability to add words to your dictionary from the keypad / word suggestion interface itself; so if it auto-corrects a word and you back up and re-spell it in it's original format an option pops up in the spelling-suggestion area to add that word.



Device: Flame 3.0 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150428010206
Gaia: 0636405f0844bf32451a375b2d61a2b16fe33348
Gecko: caf25344f73e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Flags: needinfo?(l90942025)
Apologies -  I meant *John and not Jon
(In reply to Joshua Mitchell [:Joshua_M] from comment #22)
> Hi Jon - I did have a bit of feedback on this feature - It does not seem to
> handle 2-part words well if they include a space. For example: If I add 'zug
> zug' to my dictionary, and then launch sms and begin typing, after I type
> the first 'zug' and hit space it corrects it to 'zig'. 
> If the feature is not meant to handle words with spaces in them - it might
> be a good idea to either disable the space-bar input for the add word screen
> or provide a warning that it might not work for words containing spaces.
> I realize I'm probably mis-using the feature here but I imagine some users
> might expect it to accommodate phrases as well and might interpret it as
> not-working-correctly.

I think we need to decide on this: either we disallow space in input or we show a warning, or we modify the auto correction mechanism.

I tend to favor the "disallow" or "warn" path because I'm not sure how we can tell if the user means to type "zig" or "zug zug" when he hits space after typing "zug" (as, supposedly, zig is blue-highlighted when he does so).

Omega, could you shed some light on this? Thanks.
Flags: needinfo?(l90942025) → needinfo?(ofeng)
I prefer to keep space support in the user dictionary. I think it's about the priority score each candidate gets. Can we make some tweak on the scoring mechanism to increase priority of user-defined words?
Flags: needinfo?(ofeng)
(In reply to Omega Feng [:Omega] [:馮於懋] (please ni?) from comment #25)
> I prefer to keep space support in the user dictionary. I think it's about
> the priority score each candidate gets. Can we make some tweak on the
> scoring mechanism to increase priority of user-defined words?

Yes it is possible to explicitly favor user words with spaces. Let me file a bug for that.
Depends on: 1160045
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.