[Marketplace] Application fails to install

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: leo.bugzilla.gaia, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 6/11/2013])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
STR:
  1. Open marketplace and try installing applications

Actual:
  1. Application's are installed and no error messages are displayed
  2. Some application will be installed after several tries.

Expected:
  Applications should install successfully or error should be displayed in case of failure.
(Reporter)

Updated

6 years ago
Flags: needinfo?(mattbasta)
Flags: needinfo?(jsmith)
(Reporter)

Comment 1

6 years ago
(In reply to Leo from comment #0)
> STR:
>   1. Open marketplace and try installing applications
> 
> Actual:
>   1. Application's are installed and no error messages are displayed
>   2. Some application will be installed after several tries.
> 
> Expected:
>   Applications should install successfully or error should be displayed in
> case of failure.

Applications are not installed and no error messages are displayed

Comment 2

6 years ago
I can't reproduce without logs of some kind. Press and hold the Marketplace logo, then press "Submit logs". Write the number that you're given here in the bug.
Flags: needinfo?(mattbasta)
Which applications in particular? I need a clearer STR here.
Flags: needinfo?(jsmith)

Comment 4

6 years ago
* Do the above _after_ attempting to install some apps.
(Reporter)

Comment 5

6 years ago
(In reply to Jason Smith [:jsmith] from comment #3)
> Which applications in particular? I need a clearer STR here.

Not any specific applications. I tried random applications from first page.
Reproduced in V1-train
(Reporter)

Comment 6

6 years ago
(In reply to Matt Basta [:basta] from comment #4)
> * Do the above _after_ attempting to install some apps.

I didn't get any option for "Submit logs" after long pressing Marketplace logo. Could you clarify which logo you are specifying.
(Reporter)

Comment 7

6 years ago
Created attachment 757823 [details]
Error log after trying to install single application

Please let me know if this is of any help.
Flags: needinfo?(mattbasta)

Comment 8

6 years ago
Instead of long-pressing the logo, try searching for ":debug". You should see a blue button labeled "Submit logs". Press that after you've tried to install apps.
Flags: needinfo?(mattbasta)
(Reporter)

Comment 9

6 years ago
I am not able find any such button in the marketplace application. A screenshot showing the button will be very helpful.
Flags: needinfo?(mattbasta)
I am seeing the following in the log:

06-04 11:59:38.140: E/GeckoConsole(27207): Content JS ERROR at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=e1eb5a9-51a8e43c:1 in anonymous: [install] Error installing app:  INVALID_MANIFEST
(Reporter)

Comment 11

6 years ago
hi jason, any idea how i can submit that log as matt said?
Flags: needinfo?(jsmith)
(In reply to Leo from comment #11)
> hi jason, any idea how i can submit that log as matt said?

Matt is the best person to ask here about that. I haven't tried this process yet myself.
Flags: needinfo?(jsmith)

Comment 13

6 years ago
Typing :debug in the search box and pressing enter should open a debug page. If it doesn't, it means you're using a version of Marketplace which is outdated (are you on a Geeksphone?).

In order to debug this further, I need:
- Logs submitted (this is the button: http://i.imgur.com/bv4rwf3.jpg)
- Which platform you're on
- Which apps you're trying to install
- Reliable STR
- Screenshots or other visual aids
Flags: needinfo?(mattbasta)
Can't reproduce this bug with the given information. We need exactly what Matt states above or we can't do anything here.
Whiteboard: [closeme 6/11/2013]
(Reporter)

Comment 15

6 years ago
I tried to submit logs for this issue, but strangely couldn't reproduce this problem. The log attached above clearly shows that installing failed. Please let know if any specific reason could be possible behind application failing to install
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 16

6 years ago
I have submitted an error log, received while installing the application MTV App. The Id for the submitted log is 26531.

Currently most of the applications are installing, but this doesn't.
Flags: needinfo?(mattbasta)

Comment 17

6 years ago
Since only that app is failing to install, it sounds like an issue with the app's manifest or with the platform. The Marketplace *is* trying to install it, the platform is just returning INVALID_MANIFEST.
Flags: needinfo?(mattbasta)
You need to log in before you can comment on or make changes to this bug.