"javascript:" URLs in address bar are not executed, even when browser.urlbar.filter.javascript is false

RESOLVED WONTFIX

Status

()

Firefox for Android
General
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: Tyler Freeman, Unassigned)

Tracking

21 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

This bug is in both Mobile and Desktop versions:

1. Go to about:config
2. Change "browser.urlbar.filter.javascript" to false.
3. Type "javascript:alert('hi')" in the URL address bar.


Actual results:

Nothing.


Expected results:

An alert saying "hi" should pop up. This is the only way to debug/fix misbehaving sites, since there's no console or working Firebug/Greasemonkey extension on mobile.

I would like it to turn off the annoying bar in an autoplaying Google Presentation, since it covers up my slides!
(Reporter)

Updated

4 years ago
OS: Mac OS X → Android
Hardware: x86 → ARM

Comment 1

4 years ago
bug 656433 comment 42 ?
Yes. But unlike the desktop version, there's no alternate at all.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Depends on: 680302
Resolution: --- → FIXED
Sorry, accidentally closed.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
(In reply to Tyler Freeman from comment #0)
> 1. Go to about:config
> 2. Change "browser.urlbar.filter.javascript" to false.

FWIW, that pref doesn't have anything to do with this behavior (it controls whether javascript: URIs are filtered out of autocomplete results, IIRC).

Comment 5

4 years ago
(In reply to Masatoshi Kimura [:emk] from comment #2)
> Yes. But unlike the desktop version, there's no alternate at all.

You can use the remote web console:
http://starkravingfinkle.org/blog/2012/10/firefox-for-android-remote-web-console-is-here/

Based on Gavin's comment, I'm going to WONTFIX this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.