Occasional high audio latency and sync loss in WebRTC calls

RESOLVED DUPLICATE of bug 884365

Status

()

Core
WebRTC: Audio/Video
RESOLVED DUPLICATE of bug 884365
4 years ago
4 years ago

People

(Reporter: jesup, Assigned: jesup)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRTC] [blocking-webrtc-])

(Assignee)

Description

4 years ago
In some (not all) calls, audio latency will rise and run way behind video, on the order of seconds.  Something must be buffering audio for a LONG time and getting confused about sync; I consider this separate from bug 785584, which looks at the system pipeline latencies (such as MediaStreamGraph and cubeb).

This has been seen in calls even within one house (over wifi).

It could be related to lost RTCP; bug 864654 fixes some causes of lost RTCP packets.

Comment 1

4 years ago
We too have experienced a significant latency with audio/video. We have a consistently reproducible example of this. If anyone wants to see a demo of this latency effect, please let me know and I will send you a URL and instructions to view this.
(Assignee)

Updated

4 years ago
Depends on: 901539
(Assignee)

Updated

4 years ago
Blocks: 785584
(Assignee)

Comment 2

4 years ago
Dup of both bug 884365 and bug 886886

Lew's issue is a dup of bug 901527
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 884365
You need to log in before you can comment on or make changes to this bug.