New Tab and down arrow buttons overlap the tab strip with min width

RESOLVED WORKSFORME

Status

()

Firefox
Theme
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:M?][Australis:P5])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 758196 [details]
Australis min width

When the window is shrunk to the min width, the New Tab and down arrow buttons overlap the tab strip.

Comment 1

5 years ago
This doesn't look like an Australis issue, but a general Firefox bug (in current theme too). I think it's a dupe of bug 548777.
(Reporter)

Comment 2

5 years ago
(In reply to Tim from comment #1)
> This doesn't look like an Australis issue, but a general Firefox bug (in
> current theme too). 
I don't have this issue on the current theme either with the Firefox button or the menu bar because these buttons are below the Windows buttons in that case.
Whiteboard: [Australis:M?] → [Australis:M?][Australis:P5]

Comment 3

5 years ago
(In reply to Scoobidiver from comment #2)
> (In reply to Tim from comment #1)
> > This doesn't look like an Australis issue, but a general Firefox bug (in
> > current theme too). 
> I don't have this issue on the current theme either with the Firefox button
> or the menu bar because these buttons are below the Windows buttons in that
> case.

This doesn't make sense to me; they're overlapping the tab strip, not the window buttons. That would be an issue on the Nightly default theme as well.

Updated

5 years ago
Flags: needinfo?(scoobidiver)
(Reporter)

Comment 4

5 years ago
(In reply to :Gijs Kruitbosch from comment #3)
> they're overlapping the tab strip
It's indeed the issue reported in this bug that doesn't exist with the non-Australis theme.
Flags: needinfo?(scoobidiver)

Comment 5

5 years ago
Created attachment 769606 [details]
The same issue on default theme (Linux)

I attached a screenshot of this happening on a clean profile on Linux (Release 22). Without the Firefox button, it still happens, I only need to make my window a bit smaller even. Even if it's not a literal dupe, it would still be fixed by bug 548777.

Comment 6

5 years ago
(In reply to Scoobidiver from comment #4)
> (In reply to :Gijs Kruitbosch from comment #3)
> > they're overlapping the tab strip
> It's indeed the issue reported in this bug that doesn't exist with the
> non-Australis theme.

I have to agree with Tim, I don't see how this is an issue specific to Australis.
(Reporter)

Comment 7

5 years ago
(In reply to :Gijs Kruitbosch from comment #6)
> I have to agree with Tim, I don't see how this is an issue specific to
> Australis.
See comment 2.

Comment 8

5 years ago
(In reply to Scoobidiver from comment #7)
> (In reply to :Gijs Kruitbosch from comment #6)
> > I have to agree with Tim, I don't see how this is an issue specific to
> > Australis.
> See comment 2.

See comment 4. That's not an answer. The new tab buttons overlap the tab strip. They're in the TabsToolbar. The only thing they're ever going to overlap by making the window width smaller is the tab strip, irrespective of having a firefox button or menubar or neither. Both Tim and I have pointed out the same issue happens on ordinary nightly builds. I don't understand what you think the difference is between Tim's screenshot and yours. It's the same issue.
Flags: needinfo?(scoobidiver)
(Reporter)

Comment 9

5 years ago
Created attachment 770272 [details]
Current theme min width
Flags: needinfo?(scoobidiver)
(Reporter)

Comment 10

5 years ago
With the current theme I can open a new tab or switch tabs, which I can't do with the Australis theme.

Comment 11

5 years ago
So I'd like to conclude the issue does exist on the current theme, but on Windows the min-width is large enough to prevent this, while that isn't the case on Linux.

Comment 12

5 years ago
I think this got fixed by the introduction of a minimum width for a window with toolbars.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.