Tabs are initially too high in the titlebar on Windows with sizemode=normal

RESOLVED FIXED in Firefox 28

Status

()

Firefox
Theme
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Dolske, Assigned: Gijs)

Tracking

unspecified
Firefox 28
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:M7])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
(Filed from Australis tabs ui-review #1)

There seems to be a recent regression causing Windows 7 tabs-in-titlebar to be crammed up against the top of the window. Happens sporadically, and seems to fix itself when the window is resized.
Blocks: 813802
No longer blocks: 732583
Hardware: x86 → All
Summary: tabs too far in titlebar → Tabs are initially too high in the titlebar on Windows
Dupe of bug 871279 ?
(Assignee)

Comment 2

5 years ago
(In reply to Guillaume C. [:ge3k0s] from comment #1)
> Dupe of bug 871279 ?

I suspect something else. Is the window unfocused / in the background when it is constructed?
This is a temporary issue which is resolved upon maximize/restore and happens right upon startup with a single primary browser window. I do see that those changes are not necessarily popup-specific though so you may be right. 

I actually suspect a race condition with the TabsInTitlebar measurement code.  My guess is that we're measuring the height of some elements before they're ready.
(In reply to :Gijs Kruitbosch from comment #2)
> I suspect something else. Is the window unfocused / in the background when
> it is constructed?

Yep, I can reproduce this if the window is not in the foreground upon launch.
Summary: Tabs are initially too high in the titlebar on Windows → Tabs are initially too high in the titlebar on Windows with sizemode=normal
(Assignee)

Comment 5

5 years ago
So this is caused by the window initially not having a sizemode attribute, which breaks our styles. :-\
(Assignee)

Comment 6

5 years ago
Created attachment 758505 [details] [diff] [review]
Patch

So this fixes it. However, AIUI, widget code should really be taking care of this, so I'm very reluctant to say we need to take this. Might be a good fallback if we don't find anything better, though...
Attachment #758505 - Flags: feedback?(mnoorenberghe+bmo)
(Assignee)

Comment 7

5 years ago
By the way, I did check that this gets overridden when you quit in maximized mode, and it does.
taking this to Australis M7
Whiteboard: [Australis:M?] → [Australis:M7]
(Assignee)

Comment 9

5 years ago
Comment on attachment 758505 [details] [diff] [review]
Patch

Neil said that if we depend on this, we should add it in the XUL. I think we should do this.
Attachment #758505 - Attachment description: Strawman patch → Patch
Attachment #758505 - Flags: feedback?(mnoorenberghe+bmo) → review?(mnoorenberghe+bmo)
(Assignee)

Updated

5 years ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 758505 [details] [diff] [review]
Patch

Review of attachment 758505 [details] [diff] [review]:
-----------------------------------------------------------------

Since we don't support the window feature "fullscreen" and I don't know of another way to open a window fullscreeen or maximized by default, this seems to be fine.

Nit: Update the commit message to be more specific that the sizemode is for the browser window. Specifying that the default is "normal" would also be good.

e.g. Default the sizemode attribute to "normal" on navigator:browser windows.
Attachment #758505 - Flags: review?(mnoorenberghe+bmo) → review+
(In reply to :Gijs Kruitbosch from comment #9)
> Neil said that…

By the way, this is ambiguous since there is no Neil CC'd and there is more than one that you could be referring to. No big deal in this case :)
(Assignee)

Comment 12

5 years ago
Pushed: https://hg.mozilla.org/projects/ux/rev/13e40012da07
Whiteboard: [Australis:M7] → [Australis:M7][fixed-in-ux]
(Assignee)

Comment 13

4 years ago
https://hg.mozilla.org/mozilla-central/rev/13e40012da07
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M7][fixed-in-ux] → [Australis:M7]
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.