Closed Bug 879588 Opened 7 years ago Closed 6 years ago

Tab title is hard to read in windows high-contrast mode with a light LWT (yellow text)

Categories

(Firefox :: Theme, defect)

All
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 28

People

(Reporter: Dolske, Assigned: dao)

References

Details

(Keywords: access, regression, Whiteboard: [Australis:M9][Australis:P3])

Attachments

(1 file, 1 obsolete file)

(Filed from Australis tabs ui-review #1)

screenshot_105_HighContrast1_twoPinnedWithOverflow_normal_lightLWT

https://www.flickr.com/photos/12814025@N06/8951222035/sizes/o/in/set-72157633930146585/

Screenshot shows Windows in high-contrast mode, where the selected tab has yellow text on a light-gray background.

Possibly an existing issue not new to Australis?
Note that this specific problem occurs because of the light coloured (white) lightweight theme so this is probably unlikely to happen in practice as a user wouldn't choose such a theme if they want high contrast. I suppose it's possible that a user with a light LWT turns on high contrast mode afterwards.

(fine) No LWT - screenshot_103_HighContrast1_twoPinnedWithOverflow_normal_noLWT:
https://www.flickr.com/photos/12814025@N06/8952414542/sizes/o/in/set-72157633930146585/
(fine) Dark LWT: screenshot_104_HighContrast1_twoPinnedWithOverflow_normal_darkLWT:
https://www.flickr.com/photos/12814025@N06/8952414680/sizes/o/in/set-72157633930146585/
Blocks: australis-tabs-win
No longer blocks: australis-tabs
OS: Mac OS X → Windows 7
Hardware: x86 → All
Summary: Tab title is hard to read in windows high-contrast mode (yellow text) → Tab title is hard to read in windows high-contrast mode with a light LWT (yellow text)
(In reply to Matthew N. [:MattN] from comment #1)
> Note that this specific problem occurs because of the light coloured (white)
> lightweight theme

Why are we using a native text color (yellow in this case) on a lightweight theme background?
(In reply to Dão Gottwald [:dao] from comment #2)
> (In reply to Matthew N. [:MattN] from comment #1)
> > Note that this specific problem occurs because of the light coloured (white)
> > lightweight theme
> 
> Why are we using a native text color (yellow in this case) on a lightweight
> theme background?

That seems like the issue that needs to be fixed. That isn't intentional AFAIK.
taking this to Australis M7
Whiteboard: [Australis:M?] → [Australis:M7]
This seems pretty edge-casey, so I think we shouldn't mark this as a blocker.
Whiteboard: [Australis:M7] → [Australis:M?]
Whiteboard: [Australis:M?] → [Australis:M?][Australis:P3]
(In reply to Dão Gottwald [:dao] from comment #6)
> It's this rule's fault:
> 
> http://hg.mozilla.org/projects/ux/file/634e4f218c22/browser/themes/windows/
> browser.css#l1580

This doesn't make sense to me. The problem shows on selected tabs, and that rule is for non-selected tabs, right? Or am I misreading this?
Attached patch patch (obsolete) — Splinter Review
(In reply to :Gijs Kruitbosch from comment #7)
> (In reply to Dão Gottwald [:dao] from comment #6)
> > It's this rule's fault:
> > 
> > http://hg.mozilla.org/projects/ux/file/634e4f218c22/browser/themes/windows/
> > browser.css#l1580
> 
> This doesn't make sense to me. The problem shows on selected tabs, and that
> rule is for non-selected tabs, right? Or am I misreading this?

The problem is on selected tabs because that selector excludes them.
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #794663 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 794663 [details] [diff] [review]
patch

>--- a/browser/themes/osx/browser.css
>+++ b/browser/themes/osx/browser.css
>@@ -2523,21 +2523,16 @@ toolbarbutton.chevron > .toolbarbutton-m
>   border: solid transparent;
>   border-width: 0 11px;
> }
> 
> .tabbrowser-tab:focus > .tab-stack > .tab-content > .tab-label {
>   box-shadow: @focusRingShadow@;
> }
> 
>-.tabbrowser-tab:-moz-lwtheme {
>-  color: inherit;
>-  text-shadow: inherit;
>-}

Err, text-shadow:inherit is still needed on OS X :/
Attachment #794663 - Flags: review?(gijskruitbosch+bugs)
Attached patch patch v2Splinter Review
Attachment #794663 - Attachment is obsolete: true
Attachment #794668 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 794668 [details] [diff] [review]
patch v2

Review of attachment 794668 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/themes/windows/browser.css
@@ -1466,5 @@
> -
> -.tabbrowser-tab[selected=true]:-moz-lwtheme {
> -  /* Copied from :root:-moz-lwtheme-darktext in global.css */
> -  text-shadow: 0 -0.5px 1.5px white;
> -}

I have to confess that I don't understand why this text-shadow rule had to go, too, in the context of this patch. If it's cleanup and/or the existing rule is unnecessary, can you explain how/why it is unnecessary?
The lwt text-shadow comes from global.css and is already inherited. The custom text-shadow you're looking at tried to accommodate to the selected tab being excluded in the color:inherit rule on Windows (i.e. this bug).
Comment on attachment 794668 [details] [diff] [review]
patch v2

Review of attachment 794668 [details] [diff] [review]:
-----------------------------------------------------------------

(In reply to Dão Gottwald [:dao] from comment #12)
> The lwt text-shadow comes from global.css and is already inherited. The
> custom text-shadow you're looking at tried to accommodate to the selected
> tab being excluded in the color:inherit rule on Windows (i.e. this bug).

Fab, thanks for explaining. LGTM, then!
Attachment #794668 - Flags: review?(gijskruitbosch+bugs) → review+
https://hg.mozilla.org/projects/ux/rev/306f68dadc04
Whiteboard: [Australis:M?][Australis:P3] → [Australis:P3][fixed-in-ux]
Whiteboard: [Australis:P3][fixed-in-ux] → [Australis:M9][Australis:P3][fixed-in-ux]
https://hg.mozilla.org/mozilla-central/rev/306f68dadc04
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M9][Australis:P3][fixed-in-ux] → [Australis:M9][Australis:P3]
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.