LWT doesn't affect tab-close buttons, making them hard/impossible to see in some combinations

VERIFIED FIXED in Firefox 29

Status

()

defect
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: Dolske, Assigned: Gijs)

Tracking

unspecified
Firefox 31
Points:
---

Firefox Tracking Flags

(firefox29 verified, firefox30 verified, firefox31 verified)

Details

(Whiteboard: [Australis:P4+])

Attachments

(4 attachments)

(Reporter)

Description

6 years ago
(Filed from Australis tabs ui-review #1)

Meeting notes just say "white close button on light LWT". I think we're talking about the tab-close button on background tabs; with a light LWT they look a little funky:

 https://www.flickr.com/photos/12814025@N06/8952384002/in/set-72157633932643588/

(MattN: this was your edit, can you clarify?)
Flags: needinfo?(mnoorenberghe+bmo)
Yes, that's correct, I was talking about the white close button on background tabs which doesn't look good (IMO) with a light LWT.
Flags: needinfo?(mnoorenberghe+bmo)
(Assignee)

Comment 2

6 years ago
Tentatively taking for M7.
Whiteboard: [Australis:M?] → [Australis:M7]
Stephen, what should we do in this case?
Assignee: nobody → shorlander
Status: NEW → ASSIGNED
OS: Mac OS X → Windows 7
Hardware: x86 → All
Removing the items from M7 that do not block landing on m-c.
Whiteboard: [Australis:M7] → [Australis:M?]
(Reporter)

Updated

6 years ago
Whiteboard: [Australis:M?] → [Australis:M?][Australis:P4]
(Assignee)

Comment 5

6 years ago
So a light LWT + Luna is a problem, but so is e.g. a dark LWT + Aero basic (and probably glass). I think we should just enforce certain color tab close buttons based on the LWT, just like we do for other buttons/icons/text. We already have the assets, I think, we'd just need to copy them so they're available under a separate path and use them in the tabs. Stealing back from Stephen. :-)
Assignee: shorlander → gijskruitbosch+bugs
Summary: Windows + light LWT has strange whiteish tab-close buttons → Windows + LWT doesn't change tab-close buttons, making them hard/impossible to see in some combinations
(Assignee)

Comment 6

6 years ago
OS X + dark LWT is also sadface. Will poke at this tomorrow.
OS: Windows 7 → All
Summary: Windows + LWT doesn't change tab-close buttons, making them hard/impossible to see in some combinations → LWT doesn't affect tab-close buttons, making them hard/impossible to see in some combinations
(Assignee)

Comment 7

6 years ago
This fixes windows. For some reason the OS X close icons don't have a 4th (inverted) style icon in there. I'm not sure what to do there.
Attachment #822265 - Flags: review?(mconley)
(Assignee)

Comment 8

6 years ago
Stephen, could you give us new versions of the close icon PNGs for OS X that have a 4th icon for dark LWTs?
Flags: needinfo?(shorlander)
Comment on attachment 822265 [details] [diff] [review]
windows tabclose button fixes,

Review of attachment 822265 [details] [diff] [review]:
-----------------------------------------------------------------

Windows changes look good. Thanks Gijs.
Attachment #822265 - Flags: review?(mconley) → review+
(Assignee)

Comment 10

6 years ago
Comment on attachment 822265 [details] [diff] [review]
windows tabclose button fixes,

https://hg.mozilla.org/projects/ux/rev/8662d57ab0ae
Attachment #822265 - Flags: checkin+
(Assignee)

Comment 11

6 years ago
https://hg.mozilla.org/mozilla-central/rev/8662d57ab0ae
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M?][Australis:P4] → [Australis:M9][Australis:P4]
Target Milestone: --- → Firefox 28
(Assignee)

Comment 12

5 years ago
This still isn't fixed on mac. :-(
Status: RESOLVED → REOPENED
Flags: needinfo?(shorlander)
Resolution: FIXED → ---
Whiteboard: [Australis:M9][Australis:P4] → [Australis:M9][Australis:P4] [defect] p=0
(Assignee)

Comment 13

5 years ago
Michael, do you have some time to create an inverted tabclose icon for OS X? See comment #7 and/or comment #8.
Flags: needinfo?(shorlander) → needinfo?(mmaslaney)
Sure thing. I'll have something to upload by early next week.
Flags: needinfo?(mmaslaney)
(Assignee)

Comment 15

5 years ago
(In reply to mmaslaney from comment #14)
> Sure thing. I'll have something to upload by early next week.

Excellent. :-)
Assignee: gijskruitbosch+bugs → mmaslaney
No longer blocks: fxdesktopbacklog
Whiteboard: [Australis:M9][Australis:P4] [defect] p=0 → [Australis:M9][Australis:P4]
(Reporter)

Updated

5 years ago
Whiteboard: [Australis:M9][Australis:P4] → [Australis:M9][Australis:P4+]
(Assignee)

Updated

5 years ago
Assignee: mmaslaney → gijskruitbosch+bugs
(Assignee)

Comment 17

5 years ago
This hasn't been showing up in bugmotodo for me, sigh. I should look at this the coming week, as it's a relatively easy thing to fix and relatively high impact (although, mac+lwt-only at this point...)
Status: REOPENED → ASSIGNED
Flags: needinfo?(gijskruitbosch+bugs)
(Assignee)

Updated

5 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Comment on attachment 8393175 [details] [diff] [review]
adjust close icons for OS X to deal with bright lightweight themes,

Review of attachment 8393175 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8393175 - Flags: review?(MattN+bmo) → review+
(Assignee)

Comment 20

5 years ago
remote:   https://hg.mozilla.org/integration/fx-team/rev/48b4227bb26e
Whiteboard: [Australis:M9][Australis:P4+] → [Australis:P4+][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/48b4227bb26e
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P4+][fixed-in-fx-team] → [Australis:P4+]
Target Milestone: Firefox 28 → Firefox 31
(Assignee)

Comment 22

5 years ago
Comment on attachment 8393175 [details] [diff] [review]
adjust close icons for OS X to deal with bright lightweight themes,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis / new-style tabs?
User impact if declined: users of dark lightweight themes on OSX won't be able to see close buttons on their background tabs
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low, CSS + image swap only
String or IDL/UUID changes made by this patch: none
Attachment #8393175 - Flags: approval-mozilla-beta?
Attachment #8393175 - Flags: approval-mozilla-aurora?
Attachment #8393175 - Flags: approval-mozilla-beta?
Attachment #8393175 - Flags: approval-mozilla-beta+
Attachment #8393175 - Flags: approval-mozilla-aurora?
Attachment #8393175 - Flags: approval-mozilla-aurora+
Verified fixed on Mac OS X 10.8, Ubuntu 12.04 and Windows 7 64bit using:
1. Latest Aurora, build ID: 20140509004003,
2. Firefox 30 beta 3, build ID: 20140508121358,
3. Firefox 29.0.1, build ID: 20140506152807.

The close buttons of the background tabs can be properly seen when using lightweight themes.
You need to log in before you can comment on or make changes to this bug.