Developers should be able to specify a minimum version of Firefox OS

RESOLVED WONTFIX

Status

Marketplace
General
RESOLVED WONTFIX
4 years ago
8 days ago

People

(Reporter: tofumatt, Unassigned)

Tracking

x86
Mac OS X
Points:
---

Details

(Reporter)

Description

4 years ago
I'm working on a Podcasts app for Firefox OS, but due to a platform bug I cannot ship the app to version 1.0.x devices. The minimum version Podcasts works on is 1.1. However, I can't send my app to the Marketplace for testing/submission and specify a minimum version to prevent rejection or bad reviews. iOS and possibly Android stores support this functionality, so I think we should on Firefox Marketplace as well. It would allow me to submit my app without worrying about users on older OSes installing something platform doesn't support and having a bad experience.
(Reporter)

Updated

4 years ago
Blocks: 869812
(Reporter)

Updated

4 years ago
Blocks: 879897
(Reporter)

Updated

4 years ago
No longer blocks: 869812

Comment 1

4 years ago
I mentioned this to clouserw, but the issue is that FXOS doesn't report its version to the marketplace, so we have no way to filter against that.

The solution we're going with is feature profiling (dubbed "buchets"). Is there something sniffable that detects the issue that you're running up against? If so, we can add that to our feature profile effectively solving the issue.
(Reporter)

Comment 2

4 years ago
Rob Hudson mentioned the feature detection thing as well, which is what I try to do in the app and ideally what makes sense. I think that's a much smarter way of restricting apps than developers being lazy with version numbers.

Sadly, the APIs available are exactly the same for IndexedDB and XMLHttpRequest between 1.0.1 and 1.1.0, where I tested. But 1.0.1 OOMs where 1.1.0 works fine on the same device (and the same version of b2g).

I have not a clue what the difference would be here that causes this or how to test for it, but if there were a way I'd gladly supply it.

Comment 3

4 years ago
Resolving WONTFIX since there's nothing we can do on this front. I'd just mention in the description that it might not work for users who are on older versions of Firefox OS. In your app, gracefully fail if possible and show a message suggesting that the user attempt to run a system update.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
I have the same problem!
I have an app that require Firefox OS 1.2+ but the users install in the 1.1 and report the error (and vote for the app by giving it a low rating).
The only thing that i can do it's an alert after the installation of the apps but i think that isn't a good solution.
https://marketplace.firefox.com/app/ringtone-picker
Ani news about this?
For fix in my app have insert a check of the user agent (it's the onyl way for check the Firefox OS versione in JavaScript) so when the people install my app there is an alert that block the all the function.

Comment 6

3 years ago
Reopening since people seem to be having this issue quite a lot.

Comment 7

3 years ago
I'm getting 1/5 rating votes from users that install app on Firefox OS 1.1 while I have mentioned in description that at least 1.3 is required.

Why it is not possible to add some property to "navigavor" or check app during installation, because I'm 100% sure it will not work on Firefox OS 1.1 or 1.2, and I do not have any device to test on that version, and, finally, I'm not sure I want to make it working on old version, but I can't prevent installation of app on old systems.
For resolve this problem (i hope temporary) i've written this gist https://gist.github.com/Mte90/11087561
In the ringtone picker i check the version and if the version is 1.1 i block the loading of the app with a big warning.
You need to log in before you can comment on or make changes to this bug.