Installing a search plugin (as default) doesn't change url bar behaviour

RESOLVED WORKSFORME

Status

()

Firefox
Search
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Cam, Unassigned)

Tracking

24 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 758392 [details]
Custom Search Plugin

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20130604 Firefox/24.0 (Nightly/Aurora)
Build ID: 20130604031112

Steps to reproduce:

• Installed a search plugin that provides Google's Browse by Name search (once from mycroftproject, once my own custom written plugin).
• In the modal dialog, whilst installing: checked the "start using immediately" checkbox on.
• Reordered the new plugin to be the first (top) plugin in the plugin pref pane.
• Searched using the URL bar (I tried a few sites that I know work with GBBN).
• Searched same words in searchbar
-----------------------------------------------
After much experimenting the following will produce the expected behaviour:
• Installed a search plugin that provides Google's Browse by Name search (my own custom written plugin).
• In the dropdown whilst installing checked the "start using immediately" checkbox on.
• Reordered the new plugin to be the first (top) plugin in the plugin pref pane.
• open profile folder/searchplugins
• copy in an unmolested version of my search plugin (replacing the one FF screwed up)
• open about:config
• edit browser.search.selectedEngine and browser.search.defaultenginename to both refer to the custom searchplugin.
• restart FF
• Searched using the url bar (I tried a few sites that I know work with GBBN).


Actual results:

Searchbar works as expected, taking me directly to the sites I've named.

URL bar does a normal Google search (uses the standard Google search URL format)
---------------------------------------------------------------------------------------
Much bitching and trial and error and looking at outdated docs...
---------------------------------------------------------------------------------------
Search works as expected


Expected results:

URL bar should use the search plugin's URL template. ESPECIALLY since keyword.URL is being deprecated.

I shouldn't have to fix FF's mess when I want to set a search URL.
Features shouldn't be removed until the replacement isn't broken.
Component: Untriaged → Search
Cam, could you please post a link to the search plug-in you installed, so I could try to reproduce the issue?

Your problem is that after installing the search plug-in, only the search performed from the search bar is using that plug-in, and the search performed from the URL bar doesn't?


Could you please try the following, to see if you still reproduce the issue :

1) try this with a clean profile: http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

2) running in Safe mode: http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Flags: needinfo?(camden.narzt)
(Reporter)

Comment 2

5 years ago
Well the search plugin is an attachment to the bug, but you can now find it at 
http://silversshadows.com/google-browse-by-name.xml as well.

And as of FF25.0a1 the problem seems to have been resolved whether I use a clean profile/safe-mode or just my normal profile.

In case it's relevant I was installing the plugin using scratchpad and this code:

window.external.AddSearchProvider("http://silversshadows.com/google-browse-by-name.xml");

What's interesting is that FF still changes the contents of the search plugin upon install, but now seems to be able to read the resulting file, whereas before I had to revert the changes for it to read the file.

ie most tags are prefixed with os:
Flags: needinfo?(camden.narzt)
Closing this RESOLVED WORKSFORME based on comment 2. Please reopen the bug if the issue persists.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.