If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

wrong encoding when replying to empty UTF-16 message

RESOLVED DUPLICATE of bug 961983

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 961983
4 years ago
10 months ago

People

(Reporter: Thomas Quinot, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

box
1.08 KB, application/octet-stream
Details
(Reporter)

Description

4 years ago
Created attachment 758554 [details]
box

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:17.0) Gecko/20100101 Firefox/17.0 (Beta/Release)
Build ID: 20121129165506

Steps to reproduce:

Given a message with Content-Type: text/plain;charset="UTF-16" and empty body, compose and send a reply.


Actual results:

The reply headers have Content-Type: text/plain;charset=UTF-16;format=flowed, but the reply body is encoded in us-ascii.

A mailbox file containing the original message and the reply is attached; only Received: headers have been trimmed for brevity.


Expected results:

The reply content-type header and the reply body should be consistent: either the reply body should be UTF-16-encoded, or the reply header should specify charset="us-ascii".
Component: Untriaged → Composition
Product: Thunderbird → MailNews Core

Updated

10 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 961983
You need to log in before you can comment on or make changes to this bug.