bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Flash crashes when trying to watch videos on globo.com

RESOLVED DUPLICATE of bug 902630

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
RESOLVED DUPLICATE of bug 902630
5 years ago
2 years ago

People

(Reporter: matheus.morfi, Unassigned)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 758563 [details]
bug - crash.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130512194445

Steps to reproduce:

When I use Windows 7 to navigate on globo.com I use to open lots of tabs and almost all their pages have Flash applications so when I try to play a video from them Flash usually crashes.


Actual results:

When Flash crash my Mozilla Browser stops working and I can't use it anymore until a crash report window appear then a I can choose to wait until flash works or to kill flash, usually flash never work again and meanwhile I can't use the computer cause it gets too slow.
If I choose to kill flash my browser works fine again and if I reload the video it works and I can watch it, but after the first flash's crash the probability of other flash video to crash is much bigger don't needing to have lots of tabs open, then i don't know what to make it crash.

One more thing, I don't try to play o lot of flash videos at the same time, sometimes I have a lot of tabs with videos but I start one by one and usually the first one I open is enought to crash.


Expected results:

All the flash videos should work fine with a lot of tabs open.

Comment 1

5 years ago
Type about:crashes and post some crash IDs (bp-...) related to these crashes.
Is your Flash plugin up-to-date?

Updated

5 years ago
Severity: normal → critical
Flags: needinfo?(matheus.morfi)
Keywords: crash, stackwanted
OS: Linux → Windows 7
Hardware: x86_64 → x86

Comment 3

5 years ago
Only the two first reports are recent. It's the generic Flash hang caused by a slow system:
* Please update your graphics drivers: https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration
* Try also with Lenovo's Onekey Theater disabled.
Component: Untriaged → Flash (Adobe)
Keywords: stackwanted
Product: Firefox → Plugins
Version: 21 Branch → 11.x

Updated

5 years ago
Keywords: crash → hang

Comment 4

5 years ago
I have a similar problem when trying to play Globo.com videos on Firefox 24.0 running on Ubuntu 12.04. 

As far as stated in http://www.adobe.com/software/flash/about/ I am running the latest flash plugin available for Linux (11.2.202.310). 

I don't agree that "It's the generic Flash hang caused by a slow system" because:
 * I am using a new i7 system, with Intel motherboard and 8 GB RAM and 
 * the same videos of Globo.com play normally with Chrome 29.0.1547.76 and flash 11.8.800.170.

I said that the problem is similar because, in my case, the flash/browser doesn't crash. The browser start to request more and more memory and, in a few seconds, there is no memory left and the machine becomes almost frozen due to excessive paging activity. With a lot of patience I can switch to a terminal (ctrl-alt-f1) and kill the browser process (it's necessary to wait a lot until you can type anything in the term).

I haven't seen this behaviour with videos in any other site besides globo.com. 

Here is an example of crashing video:
http://globotv.globo.com/canal-off/off-films/t/todos-os-videos/v/higher-ground/2354065/

Comment 5

5 years ago
It doesn't crash for me and the memory use is "normal" with Flash.

Did you test with a clean profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(calmch)
Sounds like https://bugzilla.mozilla.org/show_bug.cgi?id=902630

Adobe released a 11.9 beta Flash plugin which apparently fixed the problem for me on Windows. But I asked if a new 11.2 with the fix is going to be available for Linux.

If they don't make it, I'm unsure if Firefox could fix it, after all, I couldn't reproduce it with Google Chrome, Internet Explorer and Opera ?

Comment 7

5 years ago
Yes, it's a dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(calmch)
Resolution: --- → DUPLICATE
Duplicate of bug: 902630

Comment 8

5 years ago
In response to Loic comment #5, I inform that the bug is still present if I start Firefox from scratch, that is, if I quit Firefox, delete the present profile and start it again. A fresh profile is created, but the machine hangs if the pages mentioned above are loaded.

I am aware now that this bug seems to be a duplicate of bug 902630 (I'm not sure, because in my case the Flash Player doesn't crash, but instead it eats so much memory that the system almost freeze). But in this bug report or in the other one, the problem is not solved, as the plain response is that Adobe doesn't give support to Linux versions of Flash anymore.

But, as this old (11.2) Linux version works fine with most of video servers on the web, I wonder if the problem is partially on the video server side (one of Globo.com video servers). I think that if the flash (or whatever) version running on the server is changed, we could have this issue solved. Let's ask Globo.com guys to do something...

Besides that, why Firefox developer team doesn't include a newer flash version in the software package as Chrome does?

The botton line today is: if you are a Linux Firefox user, you have to install the Flash Player by yourself and you have available only an old version of it (11.2). After doing so, you can hang your machine when accessing some pages with Flash content, as the following one, for example.

http://globotv.globo.com/canal-off/off-films/t/todos-os-videos/v/higher-ground/2354065/

To avoid this problem in Linux, use Google Chrome instead of Firefox, because the first one comes with his own copy of Flash Player and it is the newest one available (11.8 presently).

Comment 9

5 years ago
It's a dupe because the Flash plugin hangs during watching these videos.

Comment 10

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 11.x → unspecified
You need to log in before you can comment on or make changes to this bug.