Closed Bug 879773 Opened 7 years ago Closed 7 years ago

Lazy loading is not working well when STK async command is received

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, major)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

RESOLVED FIXED
blocking-b2g leo+
Tracking Status
b2g18 --- fixed
b2g-v1.1hd --- fixed

People

(Reporter: frsela, Assigned: rik)

References

Details

(Keywords: regression)

Attachments

(1 file)

When an async STK command is received, settins will open the ICC page but lazy loading is not working if this load is made automatically instead manually by the user.

Now it shows a blank screen !
Kaze suggest the last Lazy loading changes could be related to this issue: https://bugzilla.mozilla.org/show_bug.cgi?id=857105
https://github.com/mozilla-b2g/gaia/pull/9991

It fails if the ICC page loading is made from this code:
https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/js/icc_menu.js#L20

To force it, you can create a little (and dirty) hack like this:
https://github.com/frsela/gaia/commit/85241115f9a730e7d3b0a0484aea28ce27faa544

so after some time, async faked STK commands will be sent to settings, settings app will be opened and will enter through the failing code.
Blocks: 875679
blocking-b2g: --- → leo?
Depends on: 857105
After bisecting, the last working commit is: c7f5c27137cc36f51c9da194292e1e5055675017

First commit failing: eb6417144696335108a7fb1700ff2cfb57d6bf45

https://github.com/mozilla-b2g/gaia/commit/eb6417144696335108a7fb1700ff2cfb57d6bf45

Asking needinfo to Rik since he implemented the patch.
Flags: needinfo?(anthony)
Hi,

Assigned to Anthony since he better knows the changes performed in Bug 857105 that might cause this regression.

Thanks.
Assignee: nobody → anthony
Blocks: 857105
No longer depends on: 857105
Regression, blocking.
blocking-b2g: leo? → leo+
Keywords: regression
Sorry I broke this. I grepped for all usages of location.host. icc_menu.js and icc.js actually replace the whole location address.
Flags: needinfo?(anthony)
Comment on attachment 761443 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10344

Fernando: Thanks a lot for the quick way to test this, this was really helpful!
Attachment #761443 - Flags: review?(frsela)
Attachment #761443 - Flags: review?(frsela) → review+
Commited on master: https://github.com/mozilla-b2g/gaia/compare/3c65d31e4e72...e3d191adfb54
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
I'm confused with the leo+ status of this bug. The original bug was not uplifted to v1-train so there's no reason to uplift this one either.

If we do uplift the original one, I'll make sure that we uplift this one as well of course.
(In reply to Anthony Ricaud (:rik) from comment #9)
> I'm confused with the leo+ status of this bug. The original bug was not
> uplifted to v1-train so there's no reason to uplift this one either.
> 
> If we do uplift the original one, I'll make sure that we uplift this one as
> well of course.

You're right, v1-train didn't fail.

This bug broked master and affected de STK refactoring work which will go to leo. I suppose your first patch (with this) will go to leo too, but I don't know
I had to commit a followup cause my patch broke the linter :(

https://github.com/mozilla-b2g/gaia/commit/81441427a3ee58410a70e79aec4a6fae40507c50
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 e3d191adfb54497524ddef31de2b6defc93bf4e7
  <RESOLVE MERGE CONFLICTS>
  git commit
  git checkout v1-train
  git cherry-pick -x  81441427a3ee58410a70e79aec4a6fae40507c50
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(anthony)
John: This bug doesn't require uplift yet. If bug 857105 gets leo+ed, we'll uplift it.
Flags: needinfo?(anthony)
Uplifted with bc9ee4e39fe3446c149c70cd2bc5f012df6b4e5f and fa16d3f57f46a8be5094c3675fe2f51df3e4a0fb
1.1hd: fa16d3f57f46a8be5094c3675fe2f51df3e4a0fb
You need to log in before you can comment on or make changes to this bug.