Closed Bug 879851 Opened 8 years ago Closed 5 years ago

[SMS][UX] Multi-recipient information panel should transition

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1162030

People

(Reporter: gnarf, Unassigned)

References

Details

We need to implement a transition for the multi-recipient information panel implemented in bug 870069.

I would like to suggest instead of a left/right slide like the thread list<->messages, we do a slide down from the header bar revealing the panel (more like extending the multi recipient panel to multi line).

cc ayman to confirm / ask for timing info - 200ms to slide down/up the whole screen?
Corey, can you give a little more detail on how urgent this is? Do we already have an implementation that works and you want to improve it, or is it currently in a broken state?
Flags: needinfo?(gnarf37)
Adding also Ayman for his input on this
Flags: needinfo?(aymanmaat)
> I would like to suggest instead of a left/right slide like the thread
> list<->messages, we do a slide down from the header bar revealing the panel
> (more like extending the multi recipient panel to multi line).

I read what your saying with this and in fact back in the day a couple of variations of what you are suggesting were proposed (in order to draw the header and its underlying content closer together - and improve the affordance of the header) but rejected due to the constraints of our current building block library. 

Therefore I am sorry but at this stage I cannot underwrite this proposed transition as it breaks the transition patterns implemented in the rest of the system and would require a completely new 'close' CTA designing and implementing and therefore new building blocks solely for the recipient panel.

Adding Victoria to CC so she has visibility of this bug
Flags: needinfo?(aymanmaat)
Triage agrees non-blocking as non functional impact.
blocking-b2g: leo? → ---
Okay - I just figured it would be a UX blocker because there is no transition here.  Though if we must implement the "slide left/right" transition, this will not be trivial.

I was suggesting the "slide down" transition because we could probably do that with just some simple CSS.
Flags: needinfo?(gnarf37)
Ayman, Is this something we are going to want to do?  Can you just close this bug down if it's something we don't care about?
Flags: needinfo?(aymanmaat)
(In reply to Corey Frang [:gnarf] from comment #6)
> Ayman, Is this something we are going to want to do?  Can you just close
> this bug down if it's something we don't care about?

I certainly care about it, but its not going to block. Nevertheless it is something we should fix because your right, there is *still* no transition there.

I know your not a fan of it, but it should be a slide left/right transition.

Any chance we could start work on it?
Flags: needinfo?(aymanmaat)
Let me talk with Rick and Julien - I think we could share a little code I wrote for Clock and enhance the method of transitioning between panels in sms in general.
(In reply to Corey Frang [:gnarf] from comment #8)
> Let me talk with Rick and Julien - I think we could share a little code I
> wrote for Clock and enhance the method of transitioning between panels in
> sms in general.

cool, thanks corey
I'd say it's probably a good idea to wait for bug 881469. Now that my other duties are done, I'll be able to focus on it and move forward faster. I plan to do a more generic way of configuring sliding between panels.
This has been fixed by bug 1162030 :)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1162030
You need to log in before you can comment on or make changes to this bug.