If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Remove Lookup methods, Xpath elements from lib/downloads.js

RESOLVED DUPLICATE of bug 908649

Status

Mozilla QA
Mozmill Tests
RESOLVED DUPLICATE of bug 908649
4 years ago
3 years ago

People

(Reporter: jfrench, Assigned: AMoz, Mentored)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [lang=js][good first bug], URL)

(Reporter)

Description

4 years ago
Split off from bug 503192, this is a marker bug to remove and replace all elementslib.Lookup methods and Xpath elements from lib/downloads.js, to support the upcoming Australis theme.
It's not only for Australis but a good move in general. Lookup expressions are too fragile for any kind of ui change. So we have to replace those with ID, Selector, or if no other base class works with NodeCollector. As template you might want to use the getElements() method we already have in addons.js or toolbar.js.
Summary: Remove Lookup methods, Xpath elements from lib/downloads.js for Australis theme support → Remove Lookup methods, Xpath elements from lib/downloads.js
Whiteboard: [mentor=whimboo][lang=js][good first bug][australis] → [mentor=whimboo][lang=js][good first bug]
(Reporter)

Comment 2

4 years ago
And the getElements() method in lib/addons.js is here
http://hg.mozilla.org/qa/mozmill-tests/file/b8a22c8c9a3b/lib/addons.js#l1026
Blocks: 503192
No longer depends on: 503192
(Assignee)

Comment 3

4 years ago
I would like to work on this bug. I would upload the patch within a while.
Amod, thank you for your interest. I will assign this bug to you then. Please ask us if you need some more information.
Assignee: nobody → amod.narvekar
Status: NEW → ASSIGNED
(Assignee)

Comment 5

4 years ago
hi whimboo. Now I am heading towards Santa Clara for Mozilla Summit 2013. I will try to find time there. Else I would resume the work after returning.
(Assignee)

Comment 6

4 years ago
Sorry whimboo, Since I am busy with my academics, I wont be able to find time before March 2, 2014. If you feel that, it is too long to wait, you are free to assign it to someone more deserving. 
Thank you. Looking forward to work with you again after I return.
Thanks Amod for the update. Actually Andrei is working on a complete refactoring of the downloads module over on bug 908649.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 908649
Mentor: hskupin@gmail.com
Whiteboard: [mentor=whimboo][lang=js][good first bug] → [lang=js][good first bug]
You need to log in before you can comment on or make changes to this bug.