Nested yield expressions should be allowed

RESOLVED DUPLICATE of bug 880447

Status

()

RESOLVED DUPLICATE of bug 880447
5 years ago
3 years ago

People

(Reporter: bbenvie, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
> function x(){ yield yield; }
> // SyntaxError: missing ; before statement

> function x(){ yield (yield); }
> // works

`yield yield` works in the V8 implementation of generators and I'm pretty sure it's allowed by the ES6 spec.

Updated

5 years ago
Blocks: 950547

Comment 1

5 years ago
What does the current spec say?
(Assignee)

Updated

4 years ago
Assignee: general → nobody
it's already fixed by bug 880447.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

3 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 880447
You need to log in before you can comment on or make changes to this bug.