Closed Bug 880098 Opened 10 years ago Closed 3 years ago

Firefox DevTools fail in frames

Categories

(DevTools :: General, defect)

23 Branch
defect
Not set
normal

Tracking

(firefox21 affected, firefox22- affected, firefox23- affected, firefox24- affected, firefox-esr17 unaffected)

RESOLVED WORKSFORME
Tracking Status
firefox21 --- affected
firefox22 - affected
firefox23 - affected
firefox24 - affected
firefox-esr17 --- unaffected

People

(Reporter: lb1.3, Unassigned)

References

Details

(Whiteboard: DUPEME)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130512193848

Steps to reproduce:

1: Inspected an item in an inner iframe of the page (Here's an example page, it doesn't matter whether it's inline or linked stylesheet in the inner frame: http://www.quackit.com/html/templates/frames/frames_example_4.html)
2: Clicked the link to open the css where a rule was defined.


Actual results:

Instead of showing the rule, it only opens the style editor to wherever it was before. I noticed this on both Firefox 21 and 22.


Expected results:

It should be aware of the frame that was selected, and not fail in this case. (It would also be awesome to have a cd(window.frames[0]) like Firebug, or a frame context selector on the console, like Chrome has.)
Component: Untriaged → Developer Tools
Regression window
Good:
http://hg.mozilla.org/mozilla-central/rev/1b7103181091
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121130 Firefox/20.0 ID:20121130020812
Bad:
http://hg.mozilla.org/mozilla-central/rev/d2fbc67f69f5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121130 Firefox/20.0 ID:20121130055213
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1b7103181091&tochange=d2fbc67f69f5

Regressed by:
	c77b869c2025	Joe Walker — Bug 788977 - [toolbox] Land the developer tools window; r=harth,jwalker,mikeratcliffe,paul,dão
Blocks: 788977
Keywords: regression
OS: Linux → All
Hardware: x86_64 → All
Version: 21 Branch → 20 Branch
Status: UNCONFIRMED → NEW
Ever confirmed: true
This regression has shipped since FF20 - no urgency to block a release on it, but will look at a low risk uplift nomination when ready.
Component: Developer Tools → Developer Tools: Source Editor
Version: 20 Branch → 23 Branch
This bug doesn't belong to the source editor component.
Component: Developer Tools: Source Editor → Developer Tools
Keywords: regression
Whiteboard: DUPEME
Product: Firefox → DevTools

I can't reproduce the bug, closing.

Honza

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.