Closed Bug 880150 Opened 6 years ago Closed 6 years ago

\EOF during CSS parsing should be treated as a U+FFFD character, or be dropped in a string

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla24

People

(Reporter: heycam, Assigned: heycam)

Details

Attachments

(1 file)

Resolution from CSS WG F2F:

http://www.w3.org/2013/06/05-css-irc#T08-32-49

means that we should treat \EOF as a U+FFFD character, or if we are in the middle of parsing a string, the backslash is dropped.
Attached patch patchSplinter Review
Assignee: nobody → cam
Status: NEW → ASSIGNED
Attachment #759041 - Flags: review?(dbaron)
Comment on attachment 759041 [details] [diff] [review]
patch

r=dbaron, though I'd have much preferred having these tests being testharness.js tests.  (We need a setup for running mochitests inside of our contribute-to-w3c-css directory, though...)
Attachment #759041 - Flags: review?(dbaron) → review+
(If you want to rewrite the tests, that would be great.)
I'm happy to rewrite the tests to be testharness.js-based, but where should I put them?  layout/reftests/w3c-css/ doesn't sound like the right place to put tests which aren't reftests.  And having something like dom/imptests/ but for tests to submit -- and getting something like the reftest submitting script working on it -- seems like a lot of work.  How about I just put them in layout/style/test/ for now?
Flags: needinfo?(dbaron)
Well, we really need a setup for testharness-based tests that we auto-export to and auto-import from the w3c repository.  We should probably set up a directory for both import and export -- e.g. layout/style/test/w3c-css/submitted/ and layout/style/test/w3c-css/incoming/ -- although maybe that's too nested?

It's ok with me if you stick it in layout/style/test for now, though.
Flags: needinfo?(dbaron)
(We can already import testharness.js tests in dom/imptests, fwiw. I suspect it would be fairly easy to import from the csswg repo as well.)
Can we export though?
We certainly can; the issue is that the existing exports and imports are ad-hoc and scattered throughout the tree (on both the mozilla and w3c sides), whereas it would be nice to do the same thing for reftests that makes it clear which side is the master copy, and makes it easy to propagate updates.
I rewrote the reftests as a single test in layout/style/test.

https://hg.mozilla.org/integration/mozilla-inbound/rev/ab27342b244c
https://hg.mozilla.org/mozilla-central/rev/ab27342b244c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
You need to log in before you can comment on or make changes to this bug.