[jsdbg2] Implement Debugger.prototype.makeDebuggeeValueFromGlobal

RESOLVED DUPLICATE of bug 914405

Status

()

RESOLVED DUPLICATE of bug 914405
5 years ago
5 years ago

People

(Reporter: simon.lindholm10, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Firebug and probably the Web Console want to use Debugger APIs without the overhead of debug mode, see https://github.com/jimblandy/DebuggerDocs/issues/7.

The simplest way forward is an API |Debugger.prototype.makeDebuggeeValueFromGlobal|, which returns the Debugger.Object version of a global without adding it as a debuggee.
(Reporter)

Comment 1

5 years ago
Created attachment 759049 [details] [diff] [review]
Implement Debugger.prototype.makeDebuggeeValueFromGlobal.

Sample patch, not tested. jimb says it looks odd, but hey.
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 914405
You need to log in before you can comment on or make changes to this bug.