Test failure "The crash reporter is enabled - 'false' should equal 'true'" in testBreakpadInstalled.js

RESOLVED FIXED

Status

Mozilla QA
Mozmill Tests
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mario garbi, Assigned: AndreeaMatei)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozmill-test-failure][sprint2013-37], URL)

(Reporter)

Description

5 years ago
We noticed this during todays testruns:
http://mozmill-ci.blargon7.com/#/functional/report/8aa237803fd4b0e7348adc8bbe39e701
(Reporter)

Updated

5 years ago
status-firefox24: --- → affected
How often does it fail? Which platforms are involved? Which branches show this problem? Please also don't add an individual report but the list of reports to the url field.
(Reporter)

Comment 2

5 years ago
I've also added the list to the URL field and a sample report in the first comment. It has failed with Firefox Nightly 24 localized builds "de", "fr" and "it".
There are 8 failures from 06/06 and another couple from 31/05.
This should be one of the #1 items for the sprint this week.
Priority: -- → P1
(Reporter)

Updated

5 years ago
Assignee: nobody → mario.garbi

Updated

5 years ago
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure][sprint2013-37]
Otilia, can we get an update for this bug? I kinda would like to know what's going on here.
(Assignee)

Comment 5

5 years ago
Looked over this today and I see it's not reproducing with en-us, only it, fr, de, Linux.
I checked the reports and tested with that 22nd June 'it' build and I can reproduce. Also the output looks like this:

With the latest 'it' build, it's not reproducing, neither with a 20th June 'it' build.

Digging more I found that in the application.ini file [1] for the failing build I don't have this line:
> [Crash Reporter]
> Enabled=1
like in the passing builds. So I assume the crashreporter is disabled for some specific builds and so crashreporter.enabled will return false. I had a mozilla-central build from one of my past bisecting that did not had that line in application.ini and I'm reproducing the failure with it.

So what options I see here, cause we have to control this somehow:
* if possible, enable it in the setupModule() if it's not already
* check if it's enabled in setupModule() and skip the test otherwise
* find out if this is a normal behavior, to have builds with disabled crashreporter. If yes and it's only for localized builds, skip it for those

[1] http://kb.mozillazine.org/Breakpad#Can_I_disable_Crash_Reporter.3F
This sounds abnormal. So as requested please file a bug against Firefox, Andreea. Thanks.
(Assignee)

Updated

5 years ago
Depends on: 887678
(Assignee)

Updated

5 years ago
Assignee: mario.garbi → andreea.matei
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Hardware: x86 → x86_64
Happened again today on 
Linux Ubuntu 12.10 (x86_64) and Linux Ubuntu 12.04 (x86_64) with Firefox 25.0a1
http://mozmill-ci.blargon7.com/#/functional/report/5aa1ca5e7015e3740d269dc947668413
http://mozmill-ci.blargon7.com/#/functional/report/5aa1ca5e7015e3740d269dc947667708
status-firefox25: --- → affected
(Assignee)

Comment 8

5 years ago
That's great news, I can update the blocking bug now. Just quickly checking I can reproduce locally with latest build.
Should be fixed with the landed patch on bug 887678. Please continue to observe the behavior and possible failures. Lets close as fixed.

This is most likely one of the most important failures we got, which brought a really serious issue into daylight. Thanks all for working on that!
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-firefox24: affected → ---
status-firefox25: affected → ---
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.