"flex-flow: column" does not work

RESOLVED DUPLICATE of bug 939905

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 939905
4 years ago
4 years ago

People

(Reporter: Iñaki Baz Castillo, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1521.3 Safari/537.36

Steps to reproduce:

A container div with "display: box" and "flex-flow: column" two div boxes with fixed height and "flex: none", while the third div box has "flex: 1 1 auto" (so it should take the rest of the container height.

See it here: http://jsfiddle.net/ibcaliax/gDv4t/


Actual results:

The result is completely wrong in Firefox (but it is properly displayed in Chrome and Opera 12).
(Reporter)

Comment 1

4 years ago
Using "flex-direction" instead of "flex-flow" shows it correctly. It seems a bug since "flex-flow" is a shorthand for setting the "flex-direction" and "flex-wrap" properties, with default value of "row nowrap".

Updated

4 years ago
Component: Untriaged → Layout
Product: Firefox → Core
Confirmed with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130814030204 CSet: 3c61cc01a3b1

Will be fixed by Bug 702508.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Component: Layout → CSS Parsing and Computation
OS: Linux → All
Hardware: x86_64 → All
Resolution: --- → DUPLICATE
Duplicate of bug: 702508
Duplicate of bug: 939905
You need to log in before you can comment on or make changes to this bug.