Closed Bug 880300 Opened 7 years ago Closed 7 years ago

Don't stat plugin libs on the main thread during startup

Categories

(Core :: Plug-ins, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 881575

People

(Reporter: vladan, Unassigned)

References

(Blocks 1 open bug)

Details

Firefox stats all registered plugins on the main thread early during startup, adding >100ms to startup time and delaying first paint.
Component: Add-ons Manager → Plug-ins
Product: Toolkit → Core
How early? This should typically be done lazily when the first web page requests a plugin.
Is this possibly triggered by the addon-manager during startup?
(In reply to Georg Fritzsche [:gfritzsche] from comment #2)
> Is this possibly triggered by the addon-manager during startup?

By default the add-ons manager shouldn't request this until about:addons opens or some other code requests it like an add-on or something like FHR that might report plugin info.

A stacktrace of the request would be useful here.
It turns out PDF.js initialization (bug 881575) + querying the MIME-type of .jsm files (bug 881578) were triggering plugin list initialization

(In reply to Benjamin Smedberg  [:bsmedberg] from comment #1)
> How early? This should typically be done lazily when the first web page
> requests a plugin.

Before first paint

(In reply to Georg Fritzsche [:gfritzsche] from comment #2)
> Is this possibly triggered by the addon-manager during startup?

What :Mossop said :)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 881575
You need to log in before you can comment on or make changes to this bug.