Last Comment Bug 880371 - mach: bootstrap support for debian
: mach: bootstrap support for debian
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla24
Assigned To: K Everets
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 11:41 PDT by K Everets
Modified: 2013-07-10 11:52 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Bootstrap support for Debian (2.13 KB, patch)
2013-06-06 11:41 PDT, K Everets
gps: feedback+
Details | Diff | Splinter Review
Bootstrap support for Debian - updated (2.53 KB, patch)
2013-06-13 05:06 PDT, K Everets
gps: review+
Details | Diff | Splinter Review

Description K Everets 2013-06-06 11:41:24 PDT
Created attachment 759311 [details] [diff] [review]
Bootstrap support for Debian

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20130606 Firefox/24.0 (Nightly/Aurora)
Build ID: 20130606082201

Steps to reproduce:

Attempted to run:

./mach bootstrap


Actual results:

$ ./mach bootstrap
Error running mach:

    ['bootstrap']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

NotImplementedError: Bootstrap support for this Linux distro not yet available.

  File "/home/keverets/src/mozilla-central.git/python/mozboot/mozboot/mach_commands.py", line 24, in bootstrap
    bootstrapper.bootstrap()
  File "/home/keverets/src/mozilla-central.git/python/mozboot/mozboot/bootstrap.py", line 53, in bootstrap
    raise NotImplementedError('Bootstrap support for this Linux '



Expected results:

$ ./mach bootstrap
Executing as root: sudo apt-get build-dep iceweasel
[sudo] password for keverets: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Executing as root: sudo apt-get install autoconf2.13 libasound2-dev libcurl4-openssl-dev libiw-dev libnotify-dev libxt-dev mercurial mesa-common-dev uuid yasm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libasound2-dev is already the newest version.
autoconf2.13 is already the newest version.
libcurl4-openssl-dev is already the newest version.
libnotify-dev is already the newest version.
libxt-dev is already the newest version.
mercurial is already the newest version.
mesa-common-dev is already the newest version.
uuid is already the newest version.
libiw-dev is already the newest version.
yasm is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Your system should be ready to build Firefox! If you have not already,
obtain a copy of the source code by running:

    hg clone https://hg.mozilla.org/mozilla-central

Or, if you prefer Git:

    git clone git://github.com/mozilla/mozilla-central.git
Comment 1 Ed Morley [:emorley] 2013-06-07 01:10:21 PDT
Comment on attachment 759311 [details] [diff] [review]
Bootstrap support for Debian

Thank you for the patch! :-)

Asking gps for review so this doesn't get missed.
Comment 2 Gregory Szorc [:gps] 2013-06-11 16:30:34 PDT
Comment on attachment 759311 [details] [diff] [review]
Bootstrap support for Debian

Review of attachment 759311 [details] [diff] [review]:
-----------------------------------------------------------------

Looking good!

You'll need to add a reference to debian.py in bin/bootstrap.py. Once you have that, I'll r+.
Comment 3 K Everets 2013-06-13 05:06:27 PDT
Created attachment 761981 [details] [diff] [review]
Bootstrap support for Debian - updated

Added the requested reference in bin/bootstrap.py.  Sorry for the omission, and thanks for the feedback!
Comment 4 Gregory Szorc [:gps] 2013-06-13 09:41:03 PDT
Comment on attachment 761981 [details] [diff] [review]
Bootstrap support for Debian - updated

Review of attachment 761981 [details] [diff] [review]:
-----------------------------------------------------------------

You don't have to apologize for the omission - it's easy to miss!

Anyway, this looks good! It can be committed with DONTBUILD since this isn't part of the build system per se.

Add "checkin-needed" to the bug keywords if you don't have repository push access and someone will magically come along and check this in for you.
Comment 5 Ryan VanderMeulen [:RyanVM] 2013-06-13 13:01:23 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/37b52a498f43
Comment 6 Ed Morley [:emorley] 2013-06-14 04:17:24 PDT
https://hg.mozilla.org/mozilla-central/rev/37b52a498f43

Note You need to log in before you can comment on or make changes to this bug.