Closed Bug 880391 Opened 8 years ago Closed 8 years ago

Don't observe mutations when panel is first populated

Categories

(Firefox :: Toolbars and Customization, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: mconley, Assigned: bwinton)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:M7][User Research Build+])

UX reported that sometimes the menu panel seems slow or janky when it is first opened.

Blake, you're currently investigating the customization transition smoothness...if you have time, can you investigate this one too?
I think we can chalk this up to sync reflows caused by the mutation observers when the panel is being first populated.
Depends on: 880701
Summary: Investigate slow menu panel deployment → Don't observe mutations when panel is first populated
Hopefully fixed by bug 880701, though there might be other performance improvements we can make on the panel later on.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.