If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Sides of AwesomeScreen are padded with light blue and look broken on tablets

VERIFIED FIXED in Firefox 23

Status

()

Firefox for Android
General
VERIFIED FIXED
4 years ago
a year ago

People

(Reporter: bnicholson, Assigned: sriram)

Tracking

({regression, reproducible})

Trunk
Firefox 25
All
Android
regression, reproducible
Points:
---

Firefox Tracking Flags

(firefox22 unaffected, firefox23+ verified, firefox24+ verified, firefox25 verified, fennec23+)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
STR:
1) Open AwesomeScreen
2) Type something

See screenshot. Haven't yet tested this on anything other than Fx24. Reproducible on Galaxy Note 10.1.
(Reporter)

Comment 1

4 years ago
Created attachment 759501 [details]
screenshot
Device or OS specific I guess, I don't see this on the Transformer TF201 (4.1)
(Reporter)

Comment 3

4 years ago
See this on Fx23, but not 22.
status-firefox22: --- → unaffected
status-firefox23: --- → affected
tracking-firefox23: --- → ?
Let's get a regression window - can someone confirm it hasn't always been like this on certain devices?
Keywords: regressionwindow-wanted
I see this issue on Samsung Galaxy Tab (Android 4.0.4) and Asus EEE Transformers (Android 4.0.3) only on Firefox for Android 23 and 24.
I will try to find a regression window.
The regressionwindow-wanted:
mozilla central:
good build: 12-04-2013
bad build:  13-04-2013

pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7b8ed29c6bc0&tochange=24a6b5ed51e3

The tinderbox inbound builds are missing since the issue is older than one month.
Bug 823644?
Flags: needinfo?(sriram)
Keywords: regressionwindow-wanted → reproducible
(Assignee)

Comment 8

4 years ago
(In reply to Teodora Vermesan (:TeoVermesan) from comment #6)
> The regressionwindow-wanted:
> mozilla central:
> good build: 12-04-2013
> bad build:  13-04-2013
> 
> pushlog:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=7b8ed29c6bc0&tochange=24a6b5ed51e3
> 
> The tinderbox inbound builds are missing since the issue is older than one
> month.

It was caused by a patch for overdraw. Please don't find a regression range. I know what bug it is :D
Flags: needinfo?(sriram)

Updated

4 years ago
Assignee: nobody → sriram
tracking-firefox23: ? → +
tracking-firefox24: ? → +

Updated

4 years ago
Status: NEW → ASSIGNED
tracking-fennec: ? → 23+
(Assignee)

Comment 9

4 years ago
Created attachment 766932 [details] [diff] [review]
Patch

This patch sets the padding to the entire tabs section and not just the view-pager.
This way, the sides are blue and the list is contained in-between.

I need to check with Ian on how the tab-widget should be. I would post a patch if we wants to change something there.
Attachment #766932 - Flags: review?(mark.finkle)
Attachment #766932 - Flags: review?(mark.finkle) → review+
this will need uplift to aurora and beta
Please nominate for uplift.
Flags: needinfo?(sriram)
(Assignee)

Comment 12

4 years ago
Created attachment 772256 [details] [diff] [review]
Patch

This is the right patch. :(
AwesomeBar needs few new styles for its lists (for the padding -- which was removed earlier). This gives the exact same result as in current release version of Firefox -- with no overdraw! win! win! WIN!
Attachment #766932 - Attachment is obsolete: true
Attachment #772256 - Flags: review?(mark.finkle)
Flags: needinfo?(sriram)
Attachment #772256 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 13

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/b6a7f3664655
(Assignee)

Comment 14

4 years ago
Comment on attachment 772256 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Overdraw in awesomebar
User impact if declined: Side of search suggestion opt-in prompt will be in a light color.
Testing completed (on m-c, etc.): Landed in m-i on 07/08. This is based on old code -- rebased for lastest code.
Risk to taking this patch (and alternatives if risky): Very less. This uses the same logic.
String or IDL/UUID changes made by this patch: None.
Attachment #772256 - Flags: approval-mozilla-beta?
Attachment #772256 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/b6a7f3664655
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25

Updated

4 years ago
Attachment #772256 - Flags: approval-mozilla-beta?
Attachment #772256 - Flags: approval-mozilla-beta+
Attachment #772256 - Flags: approval-mozilla-aurora?
Attachment #772256 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 16

4 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/5f6979e4afaa
https://hg.mozilla.org/releases/mozilla-beta/rev/239cafd191b9
status-firefox23: affected → fixed
status-firefox24: affected → fixed
status-firefox25: --- → fixed
Verified fixed on:
Build: Firefox for Android 25.0a1( 2013-07-14)
Device: Samsung Galaxy Tab
OS: Android 4.0.4
status-firefox25: fixed → verified
Verified fixed on:
Build: Firefox for Android 24.0a2( 2013-07-16)
Device: Acer Iconia
OS: Android 3.2
status-firefox24: fixed → verified

Updated

4 years ago
Status: RESOLVED → VERIFIED
Verified fixed on:
Build: Firefox for Android 23.0b6( 2013-07-17)
Device: Acer Iconia
OS: Android 3.2
status-firefox23: fixed → verified
You need to log in before you can comment on or make changes to this bug.