Closed Bug 880549 Opened 7 years ago Closed 7 years ago

Include add-on blocklist state in payload

Categories

(Firefox Health Report Graveyard :: Client: Android, defect, P2)

All
Android
defect

Tracking

(firefox23 fixed)

RESOLVED FIXED
Firefox 24
Tracking Status
firefox23 --- fixed

People

(Reporter: rnewman, Assigned: rnewman)

References

Details

Attachments

(1 file)

Ought to do this for desktop, too.

https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/Add-on_Manager/Addon

blocklistState Read only 	integer 	The current blocklist state of this add-on, see nsIBlocklistService for possible values.
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
Attachment #759539 - Flags: review?(mark.finkle)
I think we want this for v1.
Blocks: 868442
Priority: -- → P2
Comment on attachment 759539 [details] [diff] [review]
Proposed patch. v1

I can't comment on the need for v1
Attachment #759539 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/99311ea7ddce
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed in services]
Target Milestone: --- → Firefox 24
Comment on attachment 759539 [details] [diff] [review]
Proposed patch. v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
  New work.
 
User impact if declined: 
  Unable to offer tips such as "we blacklisted this add-on, which is why you're not able to use it".

Testing completed (on m-c, etc.): 
  Landed recently, so only minimal testing.

Risk to taking this patch (and alternatives if risky): 
  Very slim.

String or IDL/UUID changes made by this patch:
  None.
Attachment #759539 - Flags: approval-mozilla-aurora?
Comment on attachment 759539 [details] [diff] [review]
Proposed patch. v1

Approving as part of the body of work needed for FHR on FF23 Android.
Attachment #759539 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Firefox Health Report → Firefox Health Report Graveyard
You need to log in before you can comment on or make changes to this bug.