Closed Bug 880578 Opened 8 years ago Closed 8 years ago

APZC: Scroll events are only sent when repainting is needed

Categories

(Core :: Graphics: Layers, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla24
blocking-b2g leo+
Tracking Status
firefox22 --- wontfix
firefox23 --- wontfix
firefox24 --- fixed
b2g18 --- verified
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix
b2g-v1.1hd --- fixed

People

(Reporter: ajones, Assigned: ajones)

References

Details

(Whiteboard: [LeoVB+])

Attachments

(2 files, 1 obsolete file)

If the scroll offset changes but the effective display doesn't change then there are no updates sent. This means that the frame metrics have an out of date scroll offset and no scroll events are being sent.
Attached patch Possible fix (obsolete) — Splinter Review
Attachment #759607 - Flags: feedback?(ajones)
Comment on attachment 759607 [details] [diff] [review]
Possible fix

sounds like there are more simple/safe solution around
Attachment #759607 - Attachment is obsolete: true
Attachment #759607 - Flags: feedback?(ajones)
Attachment #760267 - Flags: feedback+
Attachment #760267 - Flags: review?(bgirard)
Attachment #760267 - Flags: review?(bgirard) → review+
https://hg.mozilla.org/mozilla-central/rev/0ba36fe91ec1
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
I think we need this on b2g18 to fix bug 892088 and maybe bug 894435.
blocking-b2g: --- → leo?
Following up in email.
According to https://bugzilla.mozilla.org/show_bug.cgi?id=894435#c6 this bug should fix bug 894435 and bug 892088.

Triage partners would like to take this on leo.
blocking-b2g: leo? → leo+
Duplicate of this bug: 892088
Duplicate of this bug: 894435
Issue verified as fixed in build: 20130726070208
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/d6e518d3ef28
Gaia: 9c868050bcc6f522f54f4afc0f0e4aa9a6149771

Scrolling is no longer jumpy and looks smooth compared to video in bug number: https://bugzilla.mozilla.org/show_bug.cgi?id=894435

We are unable to verify on the HD build.
Whiteboard: [LeoVB+]
You need to log in before you can comment on or make changes to this bug.