Closed Bug 880882 Opened 7 years ago Closed 7 years ago

handle migration of search preferences on upgrade to Firefox 23

Categories

(Firefox :: Search, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 25
Tracking Status
firefox23 + verified
firefox24 + verified

People

(Reporter: Gavin, Assigned: Gavin)

References

Details

Bug 738818 (and followup bug 860560) are landing in the Firefox 23 cycle.

Those patches enforce the invariant in Firefox that defaultEngine==currentEngine at all times, as a way to ensure that it's not possible to "silently" change the engine used only for keyword search.

One scenario those patches don't handle, though, is what happens on upgrade if a user already has differing values for defaultenginename and selectedEngine prefs. In that case, their location bar searches won't match their search bar searches until they update their search prefs somehow (e.g. by selecting a different engine in the search bar).

One way to fix this would be to just force that migration on upgrade, e.g. by setting defaultEngine = currentEngine. We need to make sure to not have a negative on partner builds, though, and think through all the potential scenarios.
I'm going to fix this as part of bug 880882
Assignee: nobody → gavin.sharp
Depends on: 885351
No longer tracking here, bug 885351 is tracked and fixed on branches.
We should track and mark as fixed, since they're really separate issues that happened to share a patch.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Adding verifyme to this bug to do some regression testing around the "migration on update" scenario.
Keywords: verifyme
Verified fixed with Firefox 23 beta 7 (build ID: 20130718163513) on: Mac OSX 10.8.3, Ubuntu 12.10 32bit and Windows 7 64bit, using the next scenario:

1) install Firefox 22 beta 6 and change the default engine (Google) from the search bar with Bing; perform some searches (only the searches executed from the search bar and from the contextual menu option are using Bing;  the searches from the URL bar and from about:home are still made with Google)

2) update to Firefox 23 beta 7: 

- Bing stays the selected engine near the search bar
- all 4 searches mentioned at 1) are performed using Bing
QA Contact: manuela.muntean
Verified fixed with Firefox 24 beta 2 (build ID: 20130812173056) on: Mac OSX 10.8.4, Ubuntu 13.04 32bit and Windows 7 64bit, using the next scenario:

1) install Firefox 23 beta 4 and change the default search engine (Google) from the search bar with Twitter; perform some searches: from the search bar, from the contextual menu option, from the URL bar and from about:home; all 4 searches are performed by Twitter

2) update to Firefox 24 beta 2: 

- Twitter stays the selected engine near the search bar
- all 4 searches mentioned at 1) are performed using Twitter
You need to log in before you can comment on or make changes to this bug.