(webapi) Aren't you overlooking volume buttons/events completely?

RESOLVED DUPLICATE of bug 839446

Status

()

defect
RESOLVED DUPLICATE of bug 839446
6 years ago
6 years ago

People

(Reporter: matteosistisette, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.93 Safari/537.36

Steps to reproduce:

https://wiki.mozilla.org/WebAPI

Most mobile devices (e.g. both Android and iPhones) have hardware volume buttons.
I can't find any feature either implemented nor planned for the future that talks about capturing input from those buttons.

It could be either conceived in terms of a sort of keypress event (event triggered when the system volume_up or volume_down buttons are pressed) or in terms of a sort of system-volume-changed event (being acknowledged that the system media volume has changed). Both could be applicable to desktop platforms too (maybe the second better than the first). Actually there may exist both options.

I'm surprised that this is being overlooked.

I guess I should somehow link this bug to https://bugzilla.mozilla.org/show_bug.cgi?id=673923 but I don't know how
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 839446
You need to log in before you can comment on or make changes to this bug.