[Buri]The DuT doesn´t match with 10 digits as required for Movistar CO.

RESOLVED DUPLICATE of bug 877302

Status

P1
normal
RESOLVED DUPLICATE of bug 877302
5 years ago
5 years ago

People

(Reporter: sync-1, Assigned: gwagner)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: khepera_44582)

(Reporter)

Description

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.131
 Firefox os  v1.0.1
 Mozilla build ID:20130606070202
 
 DEFECT DESCRIPTION:
 The DuT doesn´t match with 10 digits as required for Movistar CO.
 
  REPRODUCING PROCEDURES:
 1.  Movistar "Country" SIM Card in DuT
 2.  Turn on the DuT
 3.   Store a contact in the phonebook/SIM Card with 13 digits (i.e: XXX0987654321) ["0987654321 = National number"].
 4.   Dial the number but modifying the digits one by one from left to right, as follows;
               Step 1: 1 digits (1XXXXX7654321)
               Step 2: 2 digits (11XXXX7654321)
               Step 3: 3 digits (111XXX7654321)
               Step 4: 4 digits (1111XX7654321)
 5.- Check the alpha identifier
 
 In this moment The alpha identifier is displayed (contact name) always (step1, step2, step3 and step4).
 
  EXPECTED BEHAVIOUR:
 •	For 13 digits stored: DuT must show the alphanumeric identifier in steps 1-3, and not in step 4
 •	For 11 digits stored: DuT must show the alphanumeric identifier in step 1, and not in step 2
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:

Updated

5 years ago
blocking-b2g: --- → tef?
(Assignee)

Comment 1

5 years ago
I am a little bit confused here.
So we should do the number matching based on the length of the number the user stores?
So if the users enters a 13 digits number we should perform a 10 digits matching and if the user enters a 11 digit number we should do a 7 digit matching?

Why should a stored number like you write for step 1 (XXX0987654321) e.g: 2220987654321 match with 
e.g.: (1XXXXX7654321) 1999997654321? This would be a 7 digits and not a 10 digits matching.

Just trying to understand :)
(Assignee)

Updated

5 years ago
Assignee: nobody → anygregor
(Assignee)

Updated

5 years ago
blocking-b2g: tef? → leo?
Whiteboard: khepera_44582
needsinfo on the reporter here to help with comment #1
Flags: needinfo?(sync-1)

Comment 3

5 years ago
Joe - can you follow up with your next in person meeting?
Flags: needinfo?(jcheng)
ni? noemi to check the requirement details and blocking decision. Leo has no concern if noemi's findings are non-blocking.
Flags: needinfo?(noef)
Hi,

Asking David for certification input related to requirement details and blocking decision.
Flags: needinfo?(noef) → needinfo?(dpv)
Hi, 

This is not a blocking issue, not a mandatory requirement from the carrier. 

Thanks!
David
Flags: needinfo?(dpv)

Updated

5 years ago
blocking-b2g: leo? → ---
- due to input in comment 4 and comment 6. Renom if someone feels different
Flags: needinfo?(jcheng)
(Assignee)

Comment 8

5 years ago
and it should be fixed by bug 877302.
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 877302
(Assignee)

Updated

5 years ago
Flags: needinfo?(sync-1)
You need to log in before you can comment on or make changes to this bug.