Requesting gUM audio or video+audio on FxAndroid generates really loud static noises out of the phone's speaker

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Build: 6/9/2013 Nightly
Device: Galaxy Nexus
OS: Android 4.2
Notes: No headphones or adapters in use here.

STR

1. Go to http://mozilla.github.com/webrtc-landing/gum_test.html
2. Request audio
3. Accept permissions

Expected

The microphone should be mostly silent awaiting vocal input.

Actual

The output of the phone commonly generates a lot of static noise. With this static noise, it often becomes impossible to hear sound during a call with another peer.

This is highly problematic because most phone users using web applications using WebRTC APIs will be unable to use those apps with this bug, given that they can't effectively communicate with someone else if there's too much static noise.
tracking-fennec: --- → ?
Whiteboard: [getUserMedia][android-gum+]
Do you hear any comparable differences in the same test-case used in Chrome Beta (with WebRTC enabled in chrome://flags)?
(In reply to Aaron Train [:aaronmt] from comment #1)
> Do you hear any comparable differences in the same test-case used in Chrome
> Beta (with WebRTC enabled in chrome://flags)?

Same problem happens on Chrome Beta. Then again, Chrome Beta has it's bugs as well right now, so this could be a common bug between both browsers.
I dug into this a bit more and compared this with desktop. I think I have an idea what might be going wrong here.

What's happening here is that when we request audio in gUM, we're picking up too much sound outside of the phone. As a result, when we playback the sound, the sound is too much, resulting it being barely understandable. We need to figure out the right threshold for how much sound we pick up such that we can satisfy a Skype use case of making a phone call through Skype on the web to another person without generating too much unnecessary sound feedback.
Turns out I was not right in this bug. This is expected behavior after talking with Randell. If you try to playback media that is coming from your mic and the media is close with your mic, you are expected to get feedback, sometimes a lot.
No longer blocks: android-webrtc
Status: NEW → RESOLVED
tracking-fennec: ? → ---
Closed: 6 years ago
Resolution: --- → INVALID
Whiteboard: [getUserMedia][android-gum+]
You need to log in before you can comment on or make changes to this bug.