Remove HTML Element component from Browser product

VERIFIED FIXED

Status

()

bugzilla.mozilla.org
Administration
VERIFIED FIXED
16 years ago
6 years ago

People

(Reporter: Heikki Toivonen (remove -bugzilla when emailing directly), Assigned: asa)

Tracking

Details

Some time ago we had a meeting (I think the people on the Cc: list) about
Bugzilla components and owners. It was noted that the component "HTML Element"
was confusing, those bugs usually are either layout or parser issues, for which
there are already components for. Also the default owner for that component is
wrong. With these things in mind, we decided that the component should be
removed. Since it hasn't happened, opening a bug for it...

Comment 1

16 years ago
-> mozilla.org
Assignee: tara → asa
Component: Bugzilla → Bugzilla: Keyword & Component Changes
Product: Webtools → mozilla.org
QA Contact: matty → lchiang
Version: Bugzilla 2.13 → other

Comment 2

16 years ago
Well, you can't remove a component with 60 bugs in it, can you? Heikki, maybe
you want to move these bugs somewhere else first?

http://bugzilla.mozilla.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&field0-0-0=product&type0-0-0=substring&value0-0-0=Browser&field1-0-0=component&type1-0-0=substring&value1-0-0=HTML%20Element
Asa, this must be done soon. I just reassigned 5 bugs from Clayton's list, one
of which was a crash at CNN Europe!
(Assignee)

Comment 4

16 years ago
Heikki, as soon as you move all of the bugs in that component to some other
component(s) I can remove it.
Wasn't this your bug?

There are currently 741 bugs in HTML Element (including fixed etc.), of which 57
are still open - this should be done by changing the component via the MySQL
prompt, not by spamming thousands of people. I don't have access to Bugzilla's
MySQL database.
I would recommend just changing the component silently to Layout, without
affecting Assigned To etc., then posting a message to some newsgroups... (or
better first post a heads up, then change after a few days).
(Assignee)

Comment 6

16 years ago
I don't make changes behind the scenes like that. It doesn't capture any history
of the change and it requires bringing the database down. We've done spammy
changes for larger components than this and never done direct SQM maneuvering.
People can deal with the spam and something like a consistent comment when
moving makes a search and delete very easy.
741 bugs changed: HTML Element -> Layout. But I still think this was your job,
after all this was assigned this to you.
(Assignee)

Comment 8

16 years ago
Summary: "Remove HTML Element component from Browser product" was assigned to
me. I can do that with a click of a button if the people working in that
Component (you and others) have done the work to move the bugs to some other
Components. I'm not responsible for keeping your bugs in an orderly state.
Moving all of the bugs to Layout probably wasn't the correct move since many of
them belong to Parser or style system or some other Component. Getting them
moved to the correct Components was the heavy lifting I wasn't going to do.
Doing a mass reassign to the Layout Component would have been easy, I suppose,
but it was my hope that a more meaningful move would have happened (see, for
example, the Bugzilla Component move to the Bugzilla Product.) 
There are still about 130 bugs in the HTML Element Component. Perhaps you can
get the QA contacts in those areas to do the moving.


http://bugzilla.mozilla.org/buglist.cgi?bugidtype=include&order=bugs.bug_id&bug_id=,678,14027,17278,18168,18311,19048,21099,21232,22025,22037,22882,23780,23831,24549,26198,27986,28002,29670,30219,30998,31772,31849,31870,31911,33299,33440,34249,35063,35125,35133,35206,36855,36891,37681,37908,38387,38476,39191,40596,40680,40693,40744,41491,41633,43094,44958,45819,45840,46631,48142,48144,48147,48148,48189,49890,49892,49954,49959,49960,49961,49962,49963,49964,49967,49968,49969,49972,49974,49976,49979,49982,49984,49986,49987,50288,50294,50421,50422,50446,51403,52024,52896,53698,53908,53927,54588,54598,54664,54665,54666,55430,55475,55511,56090,56242,56246,56409,57072,57122,59669,60115,60223,62655,62801,63458,63707,65161,67777,68560,68562,68566,68644,69338,75910,76633,77373,77377,77463,80448,80449,83780,84594,87121,88106,88891,94450,95153,95170,96043,97774
Hmm... seems like Bugzilla processed my change only partially, I specifically
did the "change all" option for all of the HTML Element bugs. Changed the
remaining 130 also.

Changing wrong component to another wrong component should make no difference.
Sure, some of them should have some other component. In my opinion it would be a
waste of time to go individually through all 700+ of them to determine the right
component. The Assigned To field was not changed. The owners are free to change
the component, but I find this unlikely since HTML Element was almost certainly
also wrong. If it happened to be correct, Layout is the correct component now.
(Assignee)

Comment 10

16 years ago
Fixed. Thanks for your help heikki.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 11

16 years ago
vrfy fixed
Status: RESOLVED → VERIFIED
QA Contact: lchiang → timeless
Component: Bugzilla: Keywords & Components → Administration
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.