Intermittent mochitest Shutdown | Exited with code 11 during test run | application crashed [@ mozilla::cyclecollector::RemoveJSHolder(void*)]

RESOLVED WORKSFORME

Status

()

Core
XPCOM
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({crash, intermittent-failure})

Trunk
crash, intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=23968213&tree=Mozilla-Inbound

Ubuntu VM 12.04 mozilla-inbound opt test mochitest-4 on 2013-06-10 11:00:05 PDT for push de3610e34796
slave: tst-linux32-ec2-006

11:07:11     INFO -  16305 INFO TEST-START | Shutdown
11:07:11     INFO -  16306 INFO Passed: 13208
11:07:11     INFO -  16307 INFO Failed: 0
11:07:11     INFO -  16308 INFO Todo:   1975
11:07:11     INFO -  16309 INFO SimpleTest FINISHED
11:07:11     INFO -  16310 INFO TEST-INFO | Ran 1 Loops
11:07:11     INFO -  16311 INFO SimpleTest FINISHED
11:07:11     INFO -  NOTE: child process received `Goodbye', closing down
11:07:12  WARNING -  TEST-UNEXPECTED-FAIL | Shutdown | Exited with code 11 during test run
11:07:12     INFO -  INFO | automation.py | Application ran for: 0:05:25.724843
11:07:12     INFO -  INFO | zombiecheck | Reading PID log: /tmp/tmpUMc9jopidlog
11:07:12     INFO -  ==> process 2098 launched child process 2199
11:07:12     INFO -  ==> process 2098 launched child process 2203
11:07:12     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2199
11:07:12     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2203
11:07:12     INFO -  mozcrash INFO | Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-linux/1370881607/firefox-24.0a1.en-US.linux-i686.crashreporter-symbols.zip
11:07:12     INFO -  Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-linux/1370881607/firefox-24.0a1.en-US.linux-i686.crashreporter-symbols.zip
11:07:36  WARNING -  PROCESS-CRASH | Shutdown | application crashed [@ mozilla::cyclecollector::RemoveJSHolder(void*)]
11:07:36     INFO -  Crash dump filename: /tmp/tmpOqjUa8/minidumps/2e47b365-c4c2-fcfd-68a78bd6-74ffe5fc.dmp
11:07:36     INFO -  Operating system: Linux
11:07:36     INFO -                    0.0.0 Linux 3.2.0-23-generic-pae #36-Ubuntu SMP Tue Apr 10 22:19:09 UTC 2012 i686
11:07:36     INFO -  CPU: x86
11:07:36     INFO -       GenuineIntel family 6 model 26 stepping 5
11:07:36     INFO -       1 CPU
11:07:36     INFO -  Crash reason:  SIGSEGV
11:07:36     INFO -  Crash address: 0x11
11:07:36     INFO -  Thread 0 (crashed)
11:07:36     INFO -   0  libxul.so!mozilla::cyclecollector::RemoveJSHolder(void*) [nsCycleCollector.cpp:de3610e34796 : 3163 + 0x0]
11:07:36     INFO -      eip = 0xb58aea13   esp = 0xbff553f8   ebp = 0xbff55408   ebx = 0xb6dc7334
11:07:36     INFO -      esi = 0x8a637800   edi = 0x8a6379e0   eax = 0x00000001   ecx = 0x0000000e
11:07:36     INFO -      edx = 0xb587817f   efl = 0x00210282
11:07:36     INFO -      Found by: given as instruction pointer in context
11:07:36     INFO -   1  libxul.so!nsDocument::~nsDocument() [nsDocument.cpp:de3610e34796 : 1430 + 0x8]
11:07:36     INFO -      eip = 0xb4ebf93c   esp = 0xbff55410   ebp = 0xbff55458
11:07:36     INFO -      Found by: previous frame's frame pointer
11:07:36     INFO -   2  libxul.so!nsHTMLDocument::~nsHTMLDocument() [nsHTMLDocument.h:de3610e34796 : 38 + 0x8]
11:07:36     INFO -      eip = 0xb5023d50   esp = 0xbff55460   ebp = 0xbff55478
11:07:36     INFO -      Found by: previous frame's frame pointer
11:07:36     INFO -   3  libxul.so!nsNodeUtils::LastRelease(nsINode*) [nsNodeUtils.cpp:de3610e34796 : 259 + 0x7]
11:07:36     INFO -      eip = 0xb4ee67bf   esp = 0xbff55480   ebp = 0xbff554b8
11:07:36     INFO -      Found by: previous frame's frame pointer
11:07:36     INFO -   4  libxul.so!nsDocument::Release() [nsDocument.cpp:de3610e34796 : 1583 + 0x5]
11:07:36     INFO -      eip = 0xb4ea8901   esp = 0xbff554c0   ebp = 0xbff554e8
11:07:36     INFO -      Found by: previous frame's frame pointer
11:07:36     INFO -   5  libxul.so!XPCJSRuntime::GCCallback(JSRuntime*, JSGCStatus) [XPCJSRuntime.cpp:de3610e34796 : 628 + 0xa]
11:07:36     INFO -      eip = 0xb5371f73   esp = 0xbff554f0   ebp = 0xbff55538
11:07:36     INFO -      Found by: previous frame's frame pointer
11:07:36     INFO -   6  libxul.so!Collect [jsgc.cpp:de3610e34796 : 4586 + 0xd]
11:07:36     INFO -      eip = 0xb5eb9959   esp = 0xbff55540   ebp = 0xbff555a8
11:07:36     INFO -      Found by: previous frame's frame pointer
11:07:36     INFO -   7  libxul.so!js::GC(JSRuntime*, js::JSGCInvocationKind, JS::gcreason::Reason) [jsgc.cpp:de3610e34796 : 4604 + 0x32]
11:07:36     INFO -      eip = 0xb5eb9aac   esp = 0xbff555b0   ebp = 0xbff555c8
11:07:36     INFO -      Found by: previous frame's frame pointer
11:07:36     INFO -   8  libxul.so!js::DestroyContext(JSContext*, js::DestroyContextMode) [jscntxt.cpp:de3610e34796 : 388 + 0x16]
11:07:36     INFO -      eip = 0xb5e79d5f   esp = 0xbff555d0   ebp = 0xbff55618
11:07:36     INFO -      Found by: previous frame's frame pointer

Comment 1

5 years ago
Already a topcrash on nightly.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 881266
(Reporter)

Comment 2

5 years ago
Rather than spamming the bejesus out of bug 881266, let's leave this open for TBPL starring instead.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

5 years ago
Crash Signature: [@ mozilla::cyclecollector::RemoveJSHolder(void*) ]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.